[TR] charging problem

Bob Labuz yellowtr at adelphia.net
Fri Jul 25 07:32:35 MDT 2014


63 TR4 + ground generator system.

After arriving home last night after a 40m ride. I turned off the engine 
to open the garage door.

Noticed the ignition light still red when key in off psn. Engine stopped ok.

Tried restarting, ok but red light stayed on.

Tried this a few times and finally the red light went off when I turned 
off the key.

Tried to start the car and after a minute or so, red light went off and 
ammeter showed a + charge. So I figured maybe the control box just 
goofed up.

Looked at it this AM and now there is no charge indicated by red light 
staying on and a slight discharge at the ammeter. I pulled off all 
connections to the control box and re-attached. Cleaned the contacts in 
the box.

Took off the generator and hooked + to ground and - to the large 
terminal and it spun like a motor using my camper 12 battery downstairs.

I put a new generator on the car and same problem. It started to charge 
for a second but then the red light came on again and small discharge. 
Tested the new generator and it does not spin. I got this on sale a 
number of years ago from TRF.

So, did I test the generator correctly? Cant remember its been so long.

Or is my control box toast.

I remember Randal posting something about a manual to test the control 
box but I lost it.

Thanks for any help.


More information about the Triumphs mailing list