Subject: [TR] TR4 passenger window assembly

From: Tom Fansher <[email-masked]>
Date: Sat, 6 Sep 2025 14:25:54 -0400

I’m in need of a functional passenger side window mechanism.  The two I have will bind and are extremely hard to turn and the window jumps out of the track. One has teeth missing from the mechanism 
Ideas ?
TIA
Tom Fansher
61 TR3A
62 TR4. Needs a window regulator assembly
Sent from my iPhone
** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Allen Hess <[email-masked]>
Date: Sun, 7 Sep 2025 16:10:40 -0400

I can’t help with a replacement or the broken teeth but I can share my experience with some of the same issues. New u-channel tracks are probably available but years ago I purchased new channel, cut it to length and riveted the old brackets in place. If I remember correctly the brackets are attached to the door in slotted holes so that spacing can be set correctly. The lift mechanism has a bolt attached to the central part of the door. This bolt fits in a D shaped hole in the door which can become worn and enlarged causing misalignment and difficult operation. Finally with what you describe, the lifting arms (the X attached to the central bolt) can be bent and need to be straightened. So, your replacement mechanism may need to some or all of the above. 
Allen, been there done that, etc.

---

From: Thomas Fansher <[email-masked]>
Date: Tue, 9 Sep 2025 08:53:45 -0400

Marvin Gruber had the window assembly and it’s on the way.
Thanks again to the group for all your suggestions and support.
Tom Fansher
61 TR3A
62 TR4 now even closer to being finished

Sent from my iPad

> On Sep 7, 2025, at 4:10 PM, Allen Hess <[email-masked]> wrote:
>