Subject: [TR] Purolator filter sequence?

From: bill beecher <[email-masked]>
Date: Fri, 24 Apr 2020 10:49:31 -0500

I have the Purolator oil filter unit and canister off doing a general cleanup.  There was the occasional minor drip coming from the bolt head.  What I find it not like the illustration in the Moss catalog.  Is there a better description somewhere else?   Several of the catalog items are just marked “seal” or “washer” and are NA. 

I also have a very sturdy cupped washer on the bottom of the canister, not shown. 

Thx,
Bill
TS30800L

Stay Home, Wash Your Hands. 
** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Randall" <[email-masked]>
Date: Fri, 24 Apr 2020 08:58:47 -0700

Check out Plate G here
https://drive.google.com/open?id=0B2H2NJt34OffYjZmY2ZlYzctYzg5OC00OTc4LWE3Mm
EtMmRiODI3OTliY2Y4

Should be very close.  TRF lists the only external washer, 500321, as
available.

I believe that "sturdy cupped washer" is considered part of the housing
assembly, not serviced separately.  If you look close, you can kind of see
it in the diagram.

Note that often, oil seeps down the bottom from the joint between housing
and filter head, then drips off of the bolt.  The most common cause of that
is having an extra gasket stuck in the bottom of the groove where the two
meet.

-- Randall 
56 TR3 TS13571L once and future daily driver
71 Stag LE1473 - awaiting engine rebuild
71-2-3 Stag - awaiting gearbox rebuild 

> I have the Purolator oil filter unit and canister off doing a 
> general cleanup.  There was the occasional minor drip coming 
> from the bolt head.  What I find it not like the illustration 
> in the Moss catalog.  Is there a better description somewhere 
> else?   Several of the catalog items are just marked "seal" 
> or "washer" and are NA. 
>