Subject: [TR] ref; TR8 Question

From: Q <[email-masked]>
Date: Fri, 28 Jun 2019 11:43:26 -0700

Try this web site.

http://www.team.net/TR8/registry/

Edward Hamer

Petaluma CA

** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: James Henningsen <[email-masked]>
Date: Fri, 28 Jun 2019 18:53:52 -0400

This is perfect. Thank you!! Jim

Sent from my iPhone

> On Jun 28, 2019, at 2:43 PM, Q <[email-masked]> wrote:
> 
> Try this web site.
> 
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]