Subject: Re: [TR] Part Request TR3A Tach

From: "[email-masked]" <[email-masked]>
Date: Wed, 12 Jun 2019 09:08:09 -0500

I would first go to eBay, then call Morris at West Valley Instruments. 

NFI,
Bill

Sent from my DynaTAC 8000X

On Jun 12, 2019, at 8:31 AM, Jim Henningsen <[email-masked]> wrote:

Looking for a TR3A tachometer in good working condition.  
Jim Henningsen
Ocala, FL
60 TR3A
61 TR3A
62 TR4
75 TR6
2002 Triumph Trophy

** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs http://www.team.net/archive

** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: TERRY SMITH <[email-masked]>
Date: Wed, 12 Jun 2019 13:42:10 -0400 (EDT)

I've bought plenty of good used parts from Mike Bonaducci in Bradford, VT, including a set of new old stock AE pistons and liners.  He ships.  Phone:  802 439 5815.

No financial interest and all that....

Terry Smith, '59 TR3A  TS 58667
New Hampshire

> On June 12, 2019 at 10:08 AM "[email-masked]" <[email-masked]> wrote:
> 
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]