Subject: [TR] This is new to me...

From: Jeff Scarbrough <[email-masked]>
Date: Mon, 3 Dec 2018 11:01:58 -0500

I'd never seen a Triumph Fury before.

https://www.aronline.co.uk/concepts/concepts-and-prototypes/triumph-fury/

- Jeff
** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: "Keith Richard Stewart" <[email-masked]>
Date: Mon, 3 Dec 2018 17:51:12 -0500

Perhaps because there was only one. Many of the TR history books include photos and stories about this prototype.

Keith Stewart
[email-masked]

-----Original Message-----
From: Jeff Scarbrough <[email-masked]> 
Sent: December 3, 2018 11:02 AM
To: Triumphs ([email-masked]) <[email-masked]>
Subject: [TR] This is new to me...

- Jeff