Subject: [TR] Worst job on TR3

From: Carl Carlson <[email-masked]>
Date: Tue, 25 Dec 2018 14:22:26 -0800

All jobs on a TR3 are easy compared to a XKE 

Carl
** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: Patrick Baize <[email-masked]>
Date: Tue, 25 Dec 2018 18:14:02 -0600

haha , all jobs on an XKE are easy compared to a SAAB 95

On 12/25/2018 4:22 PM, Carl Carlson wrote:
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]
>

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus