Subject: [TR] Stag fuel pump installation

From: Frank Magnusson <[email-masked]>
Date: Fri, 16 Nov 2018 16:32:24 -0600

I'm installing the stock fuel pump and mounts on my U.S. Stag which had an aftermarket pump which finally quit and a jury rigged mount.  The issue is with the top banjo bolt.  The US Stags have a big EGR box right in fromt of the fuel pump. The ROM shows the banjo bolt pipes routed towards the front, whihc doesnt work if you have the EGR box.  The bottom banjo bolt is fine; just point it straight down.  But the only way to orient the top banjo bolt is straight up whihc isnt great since all of the pipes come in from the bottom.  Wondering what the stock installation is suppossed to look like.  Any help appreciated.  I'm assuming that the US and UK fuel pump mounts are the same...

Thanks,
Frank
'72 Stag

Sent from my iPad
** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: Frank Magnusson <[email-masked]>
Date: Sun, 18 Nov 2018 14:44:02 -0600

Thanks everybody for the help and the pictures.

What I've found is that the original line routing with the original thin plastic lines works (barely) even with the egr box.  The pipes on the original banjo bolts on the pump have a smallish OD and appear to be shorter than the replacement ones.  So the routing in the ROM just barely works withthe egr box, but it appears to be very tight.

The pipes on the new replacement banjo bolts look to have a larger OD and are longer.  That plus a rubber fuel hose instead of the original plastic line makes it too big to fit around the egr box it looks like.  The only real solution appears to be to move the pump or the egr box slightly.  It looks like there is enough room to shim the egr box away from the pump by about 1/2 inch, so thats what I am going to try.  The pump can go inwards into the fender and aft a little bit, but would require new brackets, which I really dont want to make...

Ive seen a few pics of alternate orientation of the top banjo bolt and a later pump that has the top banjo bolt perpedicular to the bottom one, so it looks to be a common problem.  But I think there is a way around it.

Thanks again for the help.

Frank
'72 Stag

Sent from my iPad