Subject: Re: [TR] Triumphs Digest, Vol 11, Issue 240

From: Anthony Rhodes <[email-masked]>
Date: Tue, 18 Sep 2018 14:52:03 -0400

I had the same problem.  I polished the outer surface of the piston and the inner surface of the dome with polishing compound.  I spent extra time on the areas which were burnished by contact with each other. It didn't take much removal of the surface.  Pretty much only needed removal of surface oxidation.   

-Tony

Sent from my 1837 Babbage Analytical Engine

> On Sep 18, 2018, at 2:00 PM, [email-masked] wrote:
> 
> Message: 2
> Date: Mon, 17 Sep 2018 12:49:30 -0700
> From: "Kinderlehrer" <[email-masked]>
> To: "'Jim Henningsen'" <[email-masked]>, "'Triumphs'"
>    <[email-masked]>
> Subject: Re: [TR] SU H6 Carb Part Need
> Message-ID: <008301d44ebf$8d50a660$a7f1f320$@net>
> Content-Type: text/plain;    charset="us-ascii"
> 
> Did you try switching the domes and see if the problem follows the dome or
> the piston? 
> Bob
> 
> -----Original Message-----
> From: Triumphs [mailto:[email-masked]] On Behalf Of Jim
> Henningsen
> Sent: Sunday, September 16, 2018 5:25 PM
> To: 'Triumphs'
> Subject: [TR] SU H6 Carb Part Need
> 
> Anyone have a spare SU H6 piston dome? Carbs on my 61 TR3A.  I believe I may
> need another as the tolerance is too tight to get the piston to move up and
> down easily and get the audible click. If you have one, please contact me
> directly.
> Thanks,
> Jim Henningsen 

** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: James Henningsen <[email-masked]>
Date: Tue, 18 Sep 2018 15:07:04 -0400

Thanks. I think my issue is the piston shaft and the tightness in the inner dome shaft.  I’ll try some polishing of the piston shaft to see if that loosens it up just slightly so it falls correctly.  Jim

Sent from my iPhone

> On Sep 18, 2018, at 2:52 PM, Anthony Rhodes <[email-masked]> wrote:
> 

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Levilevi <[email-masked]>
Date: Tue, 18 Sep 2018 16:46:59 -0600

I agree with some light sanding, it could be very little making it stick. Another thing to try is the sequence of tightening the dome screws. Set the dome on with the screws snug so that the piston goes smoothly up and down and gives that click. Slowly tighten each screw while working the piston until tight or until it sticks instead of clicks. If it sticks turn the dome to the next position e.g. Clockwise and repeat the process of tightening the dome screws. Keep moving the dome around ( make a mark to keep track of where you are). This may take many iterations, combinations, and permutations, but it's worth a try. I've made it work on some sticky SUs on a friends carbs at VTR.

Bud

Sent from my Commodore 64

> On Sep 18, 2018, at 1:07 PM, James Henningsen <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]