Subject: [Tigers] Fuel pump recommendation

From: Larry Allbritton via Tigers <[email-masked]>
Date: Sun, 15 Nov 2020 21:07:43 +0000 (UTC)

--===============7632852430812534750==
	boundary="----=_Part_5662503_377258699.1605474463092"

------=_Part_5662503_377258699.1605474463092
Content-Transfer-Encoding: 7bit

Im a long time viewer of this list and now I have a need for some advice. My Carter fuel pump quit after 20 years and would like to replace with something compatible. It has a separate Fram cannister filter. The engine is a 302 Ford Motorsports and about 270hp. It has a Holley 1850 carb.Any suggestions?

------=_Part_5662503_377258699.1605474463092
Content-Transfer-Encoding: 7bit

<html><head></head><body><div class="yahoo-style-wrap" style="font-family:Helvetica Neue, Helvetica, Arial, sans-serif;font-size:16px;"><div dir="ltr" data-setdir="false">Im a long time viewer of this list and now I have a need for some advice. My Carter fuel pump quit after 20 years and would like to replace with something compatible. It has a separate Fram cannister filter. The engine is a 302 Ford Motorsports and about 270hp. It has a Holley 1850 carb.</div><div dir="ltr" data-setdir="false">Any suggestions?<br></div></div></body></html>
------=_Part_5662503_377258699.1605474463092--

--===============7632852430812534750==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________

[email-masked]

Archive: http://www.team.net/pipermail/tigers http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]

--===============7632852430812534750==--

---

From: Ken <[email-masked]>
Date: Sun, 15 Nov 2020 14:16:47 -0700

This is a multi-part message in MIME format.
--===============4321239344707286381==
 boundary="------------6E784B9B6BDD364185117DE3"
Content-Language: en-US

This is a multi-part message in MIME format.
--------------6E784B9B6BDD364185117DE3
Content-Transfer-Encoding: 7bit

It is expensive, but: boy does it give peace of mind...

https://mossmotors.com/fuel-pump-genuine-su-double-pump-solid-state-electronic

On 11/15/2020 2:07 PM, Larry Allbritton via Tigers wrote:
> Im a long time viewer of this list and now I have a need for some 
> advice. My Carter fuel pump quit after 20 years and would like to 
> replace with something compatible. It has a separate Fram cannister 
> filter. The engine is a 302 Ford Motorsports and about 270hp. It has a 
> Holley 1850 carb.
> Any suggestions?
>
> Donate: http://www.team.net/donate.html
> Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]
>
>
-- 
Ken Tisdale
303-807-5488

--------------6E784B9B6BDD364185117DE3
Content-Transfer-Encoding: 7bit

<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  </head>
  <body>
    <p>It is expensive, but: boy does it give peace of mind...</p>
    <p><a class="moz-txt-link-freetext" href="https://mossmotors.com/fuel-pump-genuine-su-double-pump-solid-state-electronic">https://mossmotors.com/fuel-pump-genuine-su-double-pump-solid-state-electronic</a><br>
    </p>
    <div class="moz-cite-prefix">On 11/15/2020 2:07 PM, Larry Allbritton
      via Tigers wrote:<br>
    </div>
    <blockquote type="cite"
      cite="mid:[email-masked]">
      <meta http-equiv="content-type" content="text/html; charset=UTF-8">
      <div class="yahoo-style-wrap" style="font-family:Helvetica Neue,
        Helvetica, Arial, sans-serif;font-size:16px;">
        <div dir="ltr" data-setdir="false">Im a long time viewer of this
          list and now I have a need for some advice. My Carter fuel
          pump quit after 20 years and would like to replace with
          something compatible. It has a separate Fram cannister filter.
          The engine is a 302 Ford Motorsports and about 270hp. It has a
          Holley 1850 carb.</div>
        <div dir="ltr" data-setdir="false">Any suggestions?<br>
        </div>
      </div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <pre class="moz-quote-pre" wrap="">_______________________________________________

<a class="moz-txt-link-abbreviated" href="mailto:[email-masked]">[email-masked]</a>

Archive: <a class="moz-txt-link-freetext" href="http://www.team.net/pipermail/tigers">http://www.team.net/pipermail/tigers</a> <a class="moz-txt-link-freetext" href="http://autox.team.net/archive">http://autox.team.net/archive</a>

Unsubscribe: <a class="moz-txt-link-freetext" href="http://autox.team.net/mailman/options/tigers/[email-masked]">http://autox.team.net/mailman/options/tigers/[email-masked]</a>

</pre>
    </blockquote>
    <pre class="moz-signature" cols="72">-- 
Ken Tisdale
303-807-5488</pre>
  </body>
</html>

--------------6E784B9B6BDD364185117DE3--

--===============4321239344707286381==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============4321239344707286381==--