Subject: [Tigers] Tiger in USA Today

From: snakebit289 <[email-masked]>
Date: Sun, 9 Jun 2013 12:07:48 -0700 (PDT)

Nice car, belongs to Mike Michels, southern California. It was featured earlier (I think this year) on Jay Leno's Garage, so if you haven't learned enough about Mike's car
on USA Today, go to youtube and search for it. It is a sweet 1A(Oh, sorry, Terry. A B3820)

Rande
_______________________________________________

[email-masked]

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]

---

From: Owain Lloyd <[email-masked]>
Date: Sun, 9 Jun 2013 16:11:08 -0400

pity there's no 'action footage' other that the throttle blip at the start.

On Sun, Jun 9, 2013 at 3:07 PM, snakebit289 <[email-masked]> wrote:

> Nice car, belongs to Mike Michels, southern California. It was featured
> earlier (I think this year) on Jay Leno's Garage, so if you haven't learned
> enough about Mike's car
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe:
> http://autox.team.net/mailman/options/tigers/[email-masked]

[email-masked]