Subject: [Tigers] K&N Airfilter

From: Brent Edinger <[email-masked]>
Date: Tue, 30 Apr 2013 10:54:21 -0700 FILETIME=[BED104D0:01CE45CB]

Does any one have a part number for the K&N air filter with the flow though
top (X-Stream they call it)
that will fit the Tiger? I see it comes in all sorts of diameters and heights.
I'm running a performer 289
and Edelbrock carb and LAT hood.

   Thanks, Brent
_______________________________________________

[email-masked]

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]

---

From: "Smit, Theo" <[email-masked]>
Date: Tue, 30 Apr 2013 19:42:47 +0000

They only come in a circular form, so I think you'll have to go with the 9" or
11" one and then find a suitable filter and base to go with that. The K&N
filter that fits the Tiger air cleaner is originally intended for circular
applications (the K&N info lists it by internal and external diameter) and it
just happens to be flexible enough so that you can form it to the Tiger air
cleaner shape.

http://www.knfilters.com/search/product.aspx?prod=E-2859

Still, an open-top air cleaner, even in 9", should be quite a bit more
effective in overall performance than the OEM filter assembly.
Theo

________________________________

CONFIDENTIALITY NOTICE: This email and any attachments are for the sole use of
the intended recipient(s) and contain information that may be confidential
and/or legally privileged. If you have received this email in error, please
notify the sender by reply email and delete the message. Any disclosure,
copying, distribution or use of this communication (including attachments) by
someone other than the intended recipient is prohibited. Thank you.
_______________________________________________

[email-masked]

---

From: [email-masked]
Date: Tue, 30 Apr 2013 20:06:29 +0000 (UTC)

Here is the link to the K&N site and the X-stream tab http://www.knfilters.com/universal/x-stream.htm 

Looking at the installed height numbers, I think you will have a problem squeezing in one. I also have a LAT factory hood. With the stock filter and housing installed, I put lumps of modeling clay around the sides and front of the factory cleaner top. With a 1.5 inch high filter element, I did not find I had enough extra room. Depending on how high your manifold raises the carb, your results will vary from mine. 

Keep in mind that unless you are running with the rear of the hood raised, you will need to allow some space for the air to get into the top element. How much to deduct for that is your call. I considered the dropped base option to see if I could make that work. Fort some reason I thought I would not be able to do that, but do not recall why. 

What I ended up doing doing was making my on lid to use with the stock base and grafted on an 11 inch round X-stream top. When installed, I had about 1/2 inch clearance to the hood at the highest point. The 11 inch lid has an outer ring about 1 inch wide, so the air cleaner element itself is only about 9 inches in diameter. The center section for the hold down bolt is fairly large and also cuts down on the effective filter area. Just for cosmetics I did trim off the metal flange overhang at the front and back. You can do that without getting into the filtering element part. 

I am currently looking into trimming off the part of the 11 inch lid that overlays the top of the standard filter element. I do end up cutting int the element to do that. I have a plan on how to reseal that cut into part. The goal is to get that to sit down inside the standard element to gain some vertical space for a taller standard element. Since the top 3/8 inch or so of the standard element does not flow air (due to sealing material) I am not really loosing any filtering element area on the standard element. That all is a WIP. 

I do worry a bit about what would happen to my OEM fiberglass hood if I ever got a back fire through the top of the carb. I plan to some how epoxy on an aluminum plate over the top of the filter element in that area, just to be safe(r). 

If you learn of a more elegant solution, please be sure to let all of us know. 

Gene 

PS: Regarding Theo's speculation about a 9 inch lid possibly working. I have looked at that one as well. Keep in mind that the 1 inch flange cuts the actual element area down to only a 7 inch diameter circle. The center hold down section is about a 2 or 2.5 inch diameter circle. Not a lot of element area left. Probably be better off just getting a 1/2 inch taller round element. 

----- Original Message -----
From: "Brent Edinger" <[email-masked]> 
To: [email-masked] 
Sent: Tuesday, April 30, 2013 12:54:21 PM 
Subject: [Tigers] K&N Airfilter 

Thanks, Brent 

[email-masked] 

Archive: http://www.team.net/archive 
Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked] 
_______________________________________________

[email-masked]