Subject: [Super] Any photos of Judson MG26 blower pulley and mounting bracket ?

From: ver <[email-masked]>
Date: Sat, 21 May 2016 17:44:52 -0400

Hi

I just dug out my Judson for MGTC MGTF ( I think) , its model MG26

When I got it years ago the owner had adapted it to another early british car 

He changed the pulley to chain drive and made a special nose mount and bolt-on intake adapter , 

it all unbolts so that is nice :)

does anyone have a photo of what the original looks like ? , 

and what carb does it take ?

Thanks for your help
_______________________________________________
[email-masked]
Archive: http://www.team.net/archive

---

From: Paul Van Wig <[email-masked]>
Date: Sat, 21 May 2016 21:45:36 -0700

Wow been awhile since I've seen any messages here. I have a Sprite and a MGA
set up. Holly carbs never ran them but I can send some photos.  Ask again if I
forget.

Sent from my iPad

> On May 21, 2016, at 2:44 PM, ver <[email-masked]> wrote:
>
> Hi
>
>
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/superchargers/[email-masked]
_______________________________________________
[email-masked]
Archive: http://www.team.net/archive

---

From: John Seim <[email-masked]>
Date: Sun, 22 May 2016 04:52:25 -0700

George Folchi is the Judson Blower guy.
These were used on many cars, not just british.
I don't know if this will show exactly what you are looking for, but it will
get you into the neighborhood.

Try this:
http://vwjudsonregister.tripod.com/
http://www.thesamba.com/vw/archives/lit/
http://www.thesamba.com/vw/archives/lit/judson/judson_history.php

John Seim
Irvine, CA

> and what carb does it take ?
http://autox.team.net/mailman/options/superchargers/[email-masked]
_______________________________________________
[email-masked]
Archive: http://www.team.net/archive

---

From: Gene Gillam <[email-masked]>
Date: Sun, 22 May 2016 06:54:14 -0500

http://www.mg-tabc.org/supercharger/index.htm

Gene
Pardon the brevity, this was sent from my iPad

On May 21, 2016, at 11:45 PM, Paul Van Wig <[email-masked]> wrote:

Wow been awhile since I've seen any messages here. I have a Sprite and a MGA
set up. Holly carbs never ran them but I can send some photos.  Ask again if
I
forget.

Sent from my iPad

http://autox.team.net/mailman/options/superchargers/[email-masked]