Subject: Re: [Shop-talk] JB Weld Fiberweld pipe repair?

From: David Scheidt <[email-masked]>
Date: Sun, 1 Feb 2026 15:16:19 -0600

> On Jan 31, 2026, at 22:22, Mark Bradakis <[email-masked]> wrote:
> 
> Anyone have any experience with this stuff?  Have a small leak in a galvanized 1/2" supply pipe, looks like this would do nicely for a repair.

I’ve never used it, but I’ve seen it or something like it on pipes. They weren’t leaking, I assume they were before the patch. 

My experience with galvanized pipe is that if it has one hole in it, it is about to have a lot of holes. It’s better to replace the whole stick of pipe. Better still to replace all the galvanized, if possible. 

> 
> mjb.
> <78102079.avif>
> _______________________________________________
> 
> [email-masked]
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]
> 
_______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

---

From: Mark Bradakis <[email-masked]>
Date: Sun, 1 Feb 2026 18:16:45 -0700

This is a multi-part message in MIME format.
--------------F7qTjC5W7TknDRwxMMLVsCU1
Content-Transfer-Encoding: 7bit

Well I ran to Lowes and got the JB Weld kit early this morning.  Once my 
wife left for church I applied it, trying to follow the instructions as 
best I could.  Clearance was a bit tight, was tough to get the sticky 
fiberglass around the epoxy covered pipe nice and tight.  Ugly job.  Let 
it cure for the recommended hour, turned the water back on, worked just 
fine.

For about 5 hours.  Dripping again.  Looks like I will try the 
compression couplings next.  Will need two of them.  Will have to cut 
out about 5" of the old pipe with the failed repair, splice in a piece 
of pipe with a coupler on each end.  That will be a task for tomorrow.

So it goes.

mjb.

--------------F7qTjC5W7TknDRwxMMLVsCU1
Content-Disposition: attachment; filename="20260201_181335.jpg"
Content-Transfer-Encoding: base64

--------------F7qTjC5W7TknDRwxMMLVsCU1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--------------F7qTjC5W7TknDRwxMMLVsCU1--