Subject: Re: [Shop-talk] JB Weld Fiberweld pipe repair?

From: David Scheidt <[email-masked]>
Date: Sun, 1 Feb 2026 21:17:52 -0600

> On Feb 1, 2026, at 21:00, Mark Bradakis <[email-masked]> wrote:
> 
> Well I ran to Lowes and got the JB Weld kit early this morning.  Once my wife left for church I applied it, trying to follow the instructions as best I could.  Clearance was a bit tight, was tough to get the sticky fiberglass around the epoxy covered pipe nice and tight.  Ugly job.  Let it cure for the recommended hour, turned the water back on, worked just fine.
> 
> For about 5 hours.  Dripping again.  Looks like I will try the compression couplings next.  Will need two of them.  Will have to cut out about 5" of the old pipe with the failed repair, splice in a piece of pipe with a coupler on each end.  That will be a task for tomorrow.
> 
> So it goes.
> 

There’s a similar compression fitting that would allow transition to pex. Cut out as much of the galvanized as you can. It’s going to leak eventually.  

_______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

---

From: Mark Bradakis <[email-masked]>
Date: Sun, 1 Feb 2026 22:29:42 -0700

> There’s a similar compression fitting that would allow transition to pex. Cut out as much of the galvanized as you can. It’s going to leak eventually.

Yes, the whole house needs a repipe, but I was hoping that wouldn't 
happen for another 5 years or so.

Anyway, tomorrow morning I will head down to England Plumbing, a local 
shop.  The dog who always hung out down there, may he rest in peace, 
probably knew more about plumbing than most big box store employees. 
They should be able to steer me in the right direction.

mjb.

[email-masked]