Subject: [Shop-talk] Garage door openers

From: Mark Bradakis <[email-masked]>
Date: Wed, 19 Nov 2025 16:12:37 -0700

It has been nearly 40 years.  It may be time to replace our garage door 
opener.  So what are some good units to consider?  How easy are they for 
a home owner to install?  Can I do it myself, or call in a professional?

mjb.

_______________________________________________

[email-masked]
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

---

From: Brian Kemp <[email-masked]>
Date: Thu, 20 Nov 2025 18:36:58 +0000

I protected the manual release cord by using some painters tape to tape it to the arm from the opener to the door.  My door is only 7' tall and the dangling cord was in the way.  In an emergency, I can still pull the cord and just rip the tape.

I second the comment about making sure all is good with the door and springs before installing a new opener.  Another nice thing about several of the new openers is that they have a battery backup to work when the power is out.

Brian
-----Original Message-----
From: Pat Horne <[email-masked]>
Sent: Nov 20, 2025 9:23 AM
To: Mark Bradakis <[email-masked]>
Cc: <[email-masked]>
Subject: Re: [Shop-talk] Garage door openers

OK, I&rsquo;m back. I agree w/Jim, they aren&rsquo;t difficult to install, I&rsquo;ve done several by myself but it&rsquo;s easier with 2 people. Biggest problem I&rsquo;ve seen is that the door is either binding or out of balance. Make sure the door is correct before installing the opener.

I know it&rsquo;s not related to your questions, but I like to secure the manual release handle so that it&rsquo;s harder to get to from the outside by someone breaking in. It&rsquo;s pretty easy to pull the release when it&rsquo;s hanging down in the center of the door with a hook. My shaft drive has a separate automatic lock to secure the door when the door is closed &amp; the manual release is beside the door.
(Another deterrent I have is that the door is 10&rsquo; high!)
Pat Horne
We support Habitat for Humanity

On Nov 19, 2025, at 5:40 PM, Mark Bradakis wrote:

It has been nearly 40 years. It may be time to replace our garage door opener. So what are some good units to consider? How easy are they for a home owner to install? Can I do it myself, or call in a professional?

mjb.

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation $12.96
Archive:  http://autox.team.net/archive (http://www.team.net/pipermail/shop-talk)

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation $12.96
Archive:  http://autox.team.net/archive (http://www.team.net/pipermail/shop-talk)

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]