Subject: Re: [Shop-talk] oscillating saw blades.

From: Mark Miller <[email-masked]> 3l130iysahrSLI5ucBDASSdvYhAw15Kwh92xidH1at4f6a1R65DJumFT7v/LixB0vWkbNO+BeZw4b6O/LHdvyIc7pT6AjWz39HWWTGQYh0Fxxfcj27DOt6EN kaQJIMu/OHg0BaplOIvsbcuo2RnjdMEH48ByxpMChReKT/z6Uy3V6NZ0agPxWoWEaaBhG2zdAMqIgHch/lIcg6aWDwJrXN2/YbBBXf7Q5UI=
Date: Sun, 14 Sep 2025 14:11:52 -0700

I am a huge fan of the bosch carbide blades and have since switched to 
EZArc, following a recommendation from Project Farm videos (I totally 
trust all of his tool and whatever testing, at least enough to give his 
recommendations my first try).  They are really good and quite 
inexpensive, around $7-8 per blade in 3 packs at amazon 
https://a.co/d/0NebnGQ .  Nails, metal, drywall, whatever. They do clog 
up a bit with soft wood and copper, just means an occasional wipedown.

Regards,

Mark Miller   707-490-5834
[email-masked]

> Message: 2
> Date: Fri, 12 Sep 2025 03:29:23 +0000 (UTC)
> From: John T Blair <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Subject: [Shop-talk] cutting plaster and drywall
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="utf-8"
snap snip snip
>
> I bought 2.?? Well I've cut out a panel of plastered drywall which required 2 cuts floor to ceiling and then 1 horizontal cut between the 2 studs.? When I finished those cuts, it didn't look used.? I don't know how many more cuts I've made with that blade but it's still going strong.? I really didn't need the 2nd blade.? They are outstanding!!!!
> Then I went looking for a decent blade for my oscillating saw.? I went to Harbor Freight and bought 2 Titanium blades.??
> https://www.harborfreight.com/1-34-in-bi-metal-reduced-shank-titanium-plungeflush-cutting-blade-for-oscillating-multi-tools-70089.html
>
> They weren't worth squat.? Took the teeth right off of them.
> I ended up back at home depot and bought 2 of Dremil's Universal 1-1/4 in. Carbide Flush Cutting Oscillating Multi-Tool Blade (1-Piece) for about $18 ea:
> https://www.homedepot.com/pep/Dremel-Universal-1-1-4-in-Carbide-Flush-Cutting-Oscillating-Multi-Tool-Blade-1-Piece-MM485U/206384731
> Man, these are the cat's Meow!!!? I don't know how many linear feet I've cut cutting the soffits but I've still on my first blade and it's still cutting great.
>
_______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

---

From: David Scheidt <[email-masked]>
Date: Tue, 16 Sep 2025 08:21:55 -0500

> EZArc, following a recommendation from Project Farm videos (I totally

Carbide blades make oscillating tools actually useful.  Even cheap
ones are better than good HSS impulse hardened ones.  There's so much
heat generated that it's very easy to ruin the temper of the blade,
and then it's not good for anything tougher than cheese.

-- 
David Scheidt
[email-masked]

[email-masked]