Subject: [Shop-talk] Concrete Paint

From: "Matt" <[email-masked]>
Date: Sat, 26 Jul 2025 17:28:28 GMT

My 81 year old mother painted her porch & patio over a decade ago and has been quite happy with the results, but now she wants a color change.  Unfortunately the Olympic paint she used is not a current product line. I believe she got it from either HD or Lowes.  Can anyone recommend a concrete paint from fairly recent experience? The existing adhesion is fine, there is just normal wear and a little fading.  I am going to paint it for her - her floor painting days are done!

Unlike my shop floor preference, I am NOT looking for slick epoxy for this job.

TIA!
_______________________________________________

[email-masked]
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

---

From: Bob Spidell <[email-masked]> gM2rQr0yZV9cOqioZF4gwvIw4u9bnyBcyPTgEegHHCuHLv5eIcP1OPZi8CDlclL1cGZiHNLZjPXUBw==
Date: Sat, 26 Jul 2025 12:16:32 -0700

This is a multi-part message in MIME format.
--===============3973832993005362536==
 boundary="------------sYucEkq0A1ix7onxGG5sixhk"
Content-Language: en-US

This is a multi-part message in MIME format.
--------------sYucEkq0A1ix7onxGG5sixhk
Content-Transfer-Encoding: 7bit

A couple years ago I painted outdoor stair steps and a landing with this 
stuff and it's held up well. It doesn't have a really rough surface, 
like I'd expected, but has excellent non-slip properties. We did use the 
primer that it recommends (same brand). I thought the price was 
reasonable given what paint goes for these days.

https://www.lowes.com/pd/AMES-Safe-T-Deck-Greyhound-Satin-Exterior-Anti-skid-Porch-and-Floor-Paint-1-Gallon/5013817771

> Unlike my shop floor preference, I am NOT looking for slick epoxy for this job.
--------------sYucEkq0A1ix7onxGG5sixhk
Content-Transfer-Encoding: 8bit

<!DOCTYPE html>
<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  </head>
  <body>
    A couple years ago I painted outdoor stair steps and a landing with
    this stuff and it's held up well. It doesn't have a really rough
    surface, like I'd expected, but has excellent non-slip properties.
    We did use the primer that it recommends (same brand). I thought the
    price was reasonable given what paint goes for these days. <br>
    <br>
<a class="moz-txt-link-freetext" href="https://www.lowes.com/pd/AMES-Safe-T-Deck-Greyhound-Satin-Exterior-Anti-skid-Porch-and-Floor-Paint-1-Gallon/5013817771">https://www.lowes.com/pd/AMES-Safe-T-Deck-Greyhound-Satin-Exterior-Anti-skid-Porch-and-Floor-Paint-1-Gallon/5013817771</a><br>
    <br>
    <div class="moz-cite-prefix">On 7/26/2025 10:28 AM, Matt wrote:<br>
    </div>
    <blockquote type="cite"
      cite="mid:[email-masked]">
      <pre wrap="" class="moz-quote-pre">My 81 year old mother painted her porch &amp; patio over a decade ago and has been quite happy with the results, but now she wants a color change.  Unfortunately the Olympic paint she used is not a current product line. I believe she got it from either HD or Lowes.  Can anyone recommend a concrete paint from fairly recent experience? The existing adhesion is fine, there is just normal wear and a little fading.  I am going to paint it for her - her floor painting days are done!

TIA!

</pre>
    </blockquote>
  </body>
</html>

--------------sYucEkq0A1ix7onxGG5sixhk--

--===============3973832993005362536==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============3973832993005362536==--