Subject: [Shop-talk] Bathroom Floor Tile Installation

From: Jim Stone <[email-masked]>
Date: Wed, 9 Aug 2023 19:29:11 -0400

Are there any tiling experts here?  I am getting ready to tile my new bathroom floor and have hit a snag in my plans, which originally involved plywood underlayment, Laticrete Strata Mat Uncoupling Membrane and “penny” mosaic tiles.  I’ve save the details for the moment until I know if this is worth pursuing here.

Thanks,
Jim
_______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

---

From: Brian Kemp <[email-masked]>
Date: Thu, 10 Aug 2023 17:42:33 +0000

Jim - I found the forum at https://www.johnbridge.com/ to be very helpful for tile issues.  I did two bathrooms a few years ago.  I did 12x12 tiles for my floor.  The first was on a diagonal.  The second was square with the walls.  I used Ditra uncoupling membrane bought by the foot from a local flooring supply company in one bathroom over joists. I used two layers of plywood and a layer of 1/4" cement board.  My other bathroom was a concrete slab.  I used Dragon Skin (similar product to Reg Guard) as my flex layer.  Over a slab, be sure to use a concrete primer or the membrane might peel off like on my first attempt. 

For grout, I really like Custom Building Products Fusion Pro.  They say it is stain proof and has held up very well.  Read about application and micro-fiber sponges to clean as you go.  People that think they can buff off the haze the next day have issues.  I cleaned as I went and it was wonderful.

Tip - Get a nice pair of gel kneepads.

Brian
-----Original Message-----
From: Jim Stone <[email-masked]>
Sent: Aug 10, 2023 2:24 AM
To: Shop Talk <[email-masked]>
Subject: [Shop-talk] Bathroom Floor Tile Installation

Are there any tiling experts here? I am getting ready to tile my new bathroom floor and have hit a snag in my plans, which originally involved plywood underlayment, Laticrete Strata Mat Uncoupling Membrane and &ldquo;penny&rdquo; mosaic tiles. I&rsquo;ve save the details for the moment until I know if this is worth pursuing here.

Thanks,
Jim

[email-masked]
Archive:  http://autox.team.net/archive (http://www.team.net/pipermail/shop-talk)

[email-masked]

---

From: Jim Stone <[email-masked]>
Date: Thu, 10 Aug 2023 14:23:12 -0400

Thanks, Brian.  I have a very specific problem due to an incompatibility between the mosaic tile my wife bought and the uncoupling membrane (Laticrete, but I’d have the same problem with Ditra) I bought.  I will spend some time on the website and forum to see if anyone there has any suggestions.

Jim

> On Aug 10, 2023, at 1:42 PM, Brian Kemp <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]
> 
> 
> 

[email-masked]