Subject: [Shop-talk] Window lubricant

From: John Mitchell <[email-masked]>
Date: Sun, 30 Jul 2023 12:30:18 -0400

I have tilt in double hung windows, that I installed about 10 years 
ago.  It's gotten harder for my wife to open them herself and I'm 
looking for a lubricant that will not be sticky and attract dirt.  The 
windows are wood and the jamb liners have some type of fabric strip 
which I guess is what causes the friction.  I tried spraying them with 
Liquid Wrench dry lubricant, but it only helped slightly.  As for shop 
content, I plan on keeping said lubricant in the shop🙂.  Thanks for any 
advice.  Shelton, CT

_______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

---

From: Jeff Scarbrough <[email-masked]>
Date: Sun, 30 Jul 2023 12:54:14 -0400

Beeswax?

On Sun, Jul 30, 2023 at 12:48 PM John Mitchell <[email-masked]> wrote:
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]
>

[email-masked]

---

From: Jim Franklin <[email-masked]>
Date: Sun, 30 Jul 2023 12:53:10 -0400

I'm 99% sure I used Elmer's Slide-All for my wood + vinyl double hungs. It's silicone spray and worked well. 

jim

> On Jul 30, 2023, at 12:30 PM, John Mitchell <[email-masked]> wrote:
> 
> I have tilt in double hung windows, that I installed about 10 years ago.  It's gotten harder for my wife to open them herself and I'm looking for a lubricant that will not be sticky and attract dirt.  The windows are wood and the jamb liners have some type of fabric strip which I guess is what causes the friction.  I tried spraying them with Liquid Wrench dry lubricant, but it only helped slightly.  As for shop content, I plan on keeping said lubricant in the shop🙂.  Thanks for any advice.  Shelton, CT
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]
> 

[email-masked]

---

From: Brian Kemp <[email-masked]>
Date: Sun, 30 Jul 2023 10:04:35 -0700

My suggestion is Wax.

From 
https://www.weekand.com/home-garden/article/make-old-wooden-windows-slide-18033002.php

Candle wax is a go-to solution for windows that skip along in the sash 
channel as you move them rather than smoothly opening and closing. With 
the window in open position, rub candle wax or a block of paraffin along 
the sash channels left and right of the window. The sash channel is that 
area along which the frame glides. Close the window and rub wax on the 
upper part of both channels. Repeat this process once a year or whenever 
the windows seem like they need it.

On 7/30/2023 9:30 AM, John Mitchell wrote:
> content, I plan on keeping said lubricant in the shop🙂.  Thanks for 
> any advice.  Shelton, CT
>
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/shop-talk/[email-masked]
>

[email-masked]

---

From: John Mitchell <[email-masked]> mail.backend.jedi.jws.acl:role.jedi.acl.token.atz.jws.hermes.yahoo
Date: Sun, 30 Jul 2023 13:06:35 -0400

I was just thing about trying some Johnson's paste wax.  John

[email-masked]

---

From: Pat Horne <[email-masked]>
Date: Sun, 30 Jul 2023 12:19:11 -0500

I talked with a friend who restores wood windows for the last 30+ years & he said to use paraffin wax, it’s the best thing he has used. 

Peace, Pat

Pat Horne 
We support Habitat for Humanity

On Jul 30, 2023, at 11:52 AM, John Mitchell <[email-masked]> wrote:

[email-masked]

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]

---

From: Pat Horne <[email-masked]>
Date: Sun, 30 Jul 2023 12:20:48 -0500

Oh, it lasts 3-4 years. 

Pat Horne 

[email-masked]

[email-masked]

---

From: Pat Horne <[email-masked]>
Date: Sun, 30 Jul 2023 12:49:11 -0500

DON’T Try bees wax, it is sticky & will make things much worse. Paraffin wax is what is recommended. 

Peace, Pat

Pat Horne 

On Jul 30, 2023, at 12:08 PM, Jeff Scarbrough <[email-masked]> wrote:

Beeswax?

[email-masked]

[email-masked]