Subject: [Shop-talk] Ceiling Paint

From: Jim Stone <[email-masked]>
Date: Sat, 27 May 2023 10:21:32 -0400

I know this isn’t strictly “shop talk” - although I could force the issue and say I will store the leftover paint in my shop - but I am not having any luck Googling the topic and am turning to this group in desperation.  We recently added some space to our house and I have a fair amount of new ceilings to paint.  All new drywall has been, or soon will be, primed.  It has been a while since I painted ceilings but I certainly remember how difficult it can be to  know what has and has not been fully covered with white paint over white primer.  Most manufacturers have color-changing ceiling paint - goes on pink, drys white - which would certainly make the job easier.  However, the online reviews of the paint seem to be lower than comparable standard white paint.  Moreover, it looks to be difficult to buy the color-changing paint in 5 gallon buckets and the costs would certainly add up if I have to buy it by the gallon.  It isn’t a huge difference in the overall scheme of things: it would probity cost about $185 to use the color-changing paint vs. $115 for standard paint.  But, I hate to pay more for a lesser product.

Does anyone here have any experience/thoughts on the use of color-changing ceiling paint?  Is the convenience worth the drawbacks?
_______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

---

From: Pat Horne <[email-masked]>
Date: Sat, 27 May 2023 10:12:54 -0500

And also plan on at least 2 coats @ right angles so any differences are not as visible. I always use flat paint also. 

Pat Horne 
We support Habitat for Humanity

On May 27, 2023, at 9:58 AM, Karl Vacek <[email-masked]> wrote:

Not a professional painter (not even an enthusiastic one), never stayed in a Holiday Inn Express, but...

Plenty of light, with the ability to move lights to see the reflection of wet paint, and enough to see the color difference between what's dry and what you're doing now.

I use clamp lights - the ones with the big aluminum reflector - and 100W equivalent daylight LED bulbs.  Even on a small bedroom I like at least 3 lights to get light everywhere I want it.

Karl

On May 27, 2023 9:22:52 AM Jim Stone <[email-masked]> wrote:

> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]