Subject: [Shop-talk] Smoke gun for septic vent leak?

From: Jim Franklin <[email-masked]>
Date: Wed, 23 Nov 2022 08:51:10 -0500

Apologies if I've asked this before, I can't find any emails from it. I rent a basement apartment with a sewage ejection pump. When the weather gets cold, it stinks, almost exclusively while I'm in the shower. After many investigations and lots of thought, I think there's a leak in the vent side. As the catchment tank fills up, the air above the liquid can't push the cold slug of air in the vent pipe, so it exits through the leak. 

A plumber has been here 3 times, and yesterday replaced the noisy and banging backflow prevention valve, but either he's a nancy boy who doesn't wnt to dive any further down the waste side, or is clueless, because his excuse is that it's very hard to diagnose odors. Or maybe he's doing it for free as a friend of the landlord and doesn't want to create an all day job he won't get paid for.

I'd like send a large volume of visible air down the vent and see if it leaks out somewhere. I'm thinking I'd drill two small holes- one for a balloon which I'd inflate to seal the vent, and one below it for a smoke gun. Sound plausible? Better way to do this? Is there such a thing as a high volume smoke gun for consumer prices?

I've tried soapy water and smoke sticks to look for escaping air, but it was inconclusive; I think I need positive pressure inside the system. I suppose I could install a coupler in the vent and use the compressor and aforementioned smoke sticks, but I'm looking for a better plan A. 

thanks,
jim
_______________________________________________

[email-masked]
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

---

From: "Matt" <[email-masked]>
Date: Wed, 23 Nov 2022 14:50:55 GMT

I had a similar issue in my shop where I have a small tank with pump to get sewage over a small hill before gravity takes over.  But in my case the vents are not up through the roofline so my approach was simply to flush the tank by running the tap for an extended period. I would only have the smell a couple of time a year.

if your vent line is in the wall, it will be interesting whether you could get the smoke to show itself.  I know smells can find a way through, not sure whether smoke has the same penetration...  Another potential solution is a small blower in the vent line...

Good luck and let us know how it plays out

---------- Original Message ----------
From: Jim Franklin <[email-masked]>
To: shop-talk <[email-masked]>
Subject: [Shop-talk] Smoke gun for septic vent leak?
Date: Wed, 23 Nov 2022 08:51:10 -0500

thanks,
jim

[email-masked]

[email-masked]