Subject: [Shop-talk] Jet Table Saw

From: Jeff Scarbrough <[email-masked]>
Date: Sun, 14 Aug 2022 11:40:02 -0400

Got a Jet table saw from a friend yesterday.  It needs a good bit of
cleaning up, and a few parts (fence rails, etc.)  Before I get too
deep into it, I wanted to see what parts are available.

It's a Jet JPS-10 from 1989.  Apparently Jet still make a JPS-10, but
it looks much different.  Trying to find parts on their site or
ereplacementparts.com is proving frustrating.

There is a stock number on the saw (706429) but that doesn't seem to
mnarrow down the field much.

Anyone know of a source for Jet parts that can be navigated by
multiple models with the same number?

Thanks!

P.S. This would be a replacement for a Craftsman saw from 1955 which
works great but uses 8" blades which are rare and expensive.  Been
using circular saw blades with a bushing for 30 years, but that's
getting old, as am I.
_______________________________________________

[email-masked]
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

---

From: Tom Coradeschi <[email-masked]>
Date: Mon, 15 Aug 2022 19:18:31 -0400

Jet makes nice stuff, but support is a bit of a crapshoot. I have a JWTS-10, which is probably the same basic saw, just 10 years or so newer. I grab the part numbers for the few I have needed, and let google do the searching. 

Tom Coradeschi
[email-masked]

> On Aug 14, 2022, at 12:30 PM, Jeff Scarbrough <[email-masked]> wrote:
> 
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]
> 

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]