Subject: Re: [Shop-talk] Good quality garden hose

From: DAVID MASSEY <[email-masked]>
Date: Mon, 4 Jul 2022 13:33:20 +0000 (UTC)

--===============1200597134611036211==
	boundary="----=_Part_1725976_1589295636.1656941600198"

------=_Part_1725976_1589295636.1656941600198
Content-Transfer-Encoding: quoted-printable

 Hat's off to Jimmie for his recommendation of the Flexzilla hose.=C2=A0 I =
bought a 50 ft as a trial and the wife loved it so I bought a 100 ft hose f=
or the other side of the house.=C2=A0=20

They ain't cheap, though.=C2=A0 Is it worth it?=C2=A0 It depends.=C2=A0 If =
you drag the hose out once or twice a month to wash the car or hose off the=
 patio, probably not.=C2=A0 But my wife is an avid gardener and she will us=
e the hose every morning to water the potted plants, window boxes and other=
 selected plants.=C2=A0 She loves it.=C2=A0 Much easier to drag around the =
yard and wind back up on the hose reel.
I'm thinking of getting a 5 footer for the brewery.
=20
Dave=20

=20
=20
-----Original Message-----
From: Jimmie Mayfield <[email-masked]>
To: [email-masked]
Sent: Mon, Mar 28, 2022 4:28 pm
Subject: Re: [Shop-talk] Good quality garden hose

  I can't speak for its longevity but I bought a 100ft Flexzilla hose about=
 4 years ago.=C2=A0 It's easily the most flexible garden hose I've ever use=
d, even when pressurized.=C2=A0 It's not kink-proof but kinks...almost don'=
t matter?=C2=A0 When my other two hoses kink I have to stop what I'm doing,=
 walk over to the kink and manually untwist it.=C2=A0 But this hose is flex=
ible enough that I just need to "flick" it like a whip and the kink usually=
 undoes itself.=C2=A0=20
 =20
  I'm really tempted to buy one of those 4000psi Flexzilla pressure washer =
hoses this year.=C2=A0 I loathe having to wrestle with my current pressure =
washer hose...=20
  -- J
 =20
 =20
  On 3/28/22 14:46, Brian and Wendy Warrick wrote:
 =20
 #yiv7409233758 P {margin-top:0;margin-bottom:0;}  Does anyone have a recom=
mendation for a good quality garden hose that won't kink and last more than=
 a couple of years? I need to replace one that was done at the end of last =
fall. I have one that is a seafoam green color with the word "contractor" i=
mprinted on it, but I have been unable to find it online. I bought it at Co=
stco probably 15 years ago and it has been a great hose. =20
   Cost isn't really an issue. I am looking for good quality. =20
   Thanks  Brian Warrick  Nampa, ID=20
  _______________________________________________

[email-masked]
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/arch=
ive

[email-masked]

=20
=20
  _______________________________________________

[email-masked]
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/arch=
ive

[email-masked]

------=_Part_1725976_1589295636.1656941600198
Content-Transfer-Encoding: 7bit

<div style="color:black;font: 12pt Arial, Helvetica, sans-serif;">
<div> <font size="3">Hat's off to Jimmie for his recommendation of the Flexzilla hose.&nbsp; I bought a 50 ft as a trial and the wife loved it so I bought a 100 ft hose for the other side of the house.&nbsp; <br>
</font></div>

<div><font size="3"><br>
</font></div>

<div><font size="3">They ain't cheap, though.&nbsp; Is it worth it?&nbsp; It depends.&nbsp; If you drag the hose out once or twice a month to wash the car or hose off the patio, probably not.&nbsp; But my wife is an avid gardener and she will use the hose every morning to water the potted plants, window boxes and other selected plants.&nbsp; She loves it.&nbsp; Much easier to drag around the yard and wind back up on the hose reel.</font></div>

<div><font size="3"><br>
</font></div>

<div><font size="3">I'm thinking of getting a 5 footer for the brewery.<br>
</font></div>

<div><font size="3"> </font><br>
</div>

<div style="clear:both">
<div style="color:black;font:12pt Arial, Helvetica, sans-serif;">
<div><font size="4">Dave <br>
</font></div>

<div><font size="3"><span style="font-size: 10pt; color: black;"><br>
</span></font></div>
<br>
</div>
</div>

<div> <br>
</div>

<div> <br>
</div>

<div style="font-family:arial,helvetica;font-size:10pt;color:black"><font size="2">-----Original Message-----<br>
From: Jimmie Mayfield &lt;[email-masked]&gt;<br>
To: [email-masked]<br>
Sent: Mon, Mar 28, 2022 4:28 pm<br>
Subject: Re: [Shop-talk] Good quality garden hose<br>
<br>

<div id="yiv7409233758">

  
<div>
    
<div class="yiv7409233758moz-cite-prefix">I can't speak for its longevity but I
      bought a 100ft Flexzilla hose about 4 years ago.&nbsp; It's easily the
      most flexible garden hose I've ever used, even when pressurized.&nbsp;
      It's not kink-proof but kinks...almost don't matter?&nbsp; When my
      other two hoses kink I have to stop what I'm doing, walk over to
      the kink and manually untwist it.&nbsp; But this hose is flexible
      enough that I just need to "flick" it like a whip and the kink
      usually undoes itself.&nbsp; <br>

    </div>

<div class="yiv7409233758moz-cite-prefix"><br>

    </div>

<div>I'm really tempted to buy one of those 4000psi Flexzilla pressure
      washer hoses this year.&nbsp; I loathe having to wrestle with my
      current pressure washer hose...</div>

<div class="yiv7409233758moz-cite-prefix"><br>

    </div>

<div class="yiv7409233758moz-cite-prefix">-- J<br>

    </div>

<div class="yiv7409233758moz-cite-prefix"><br>

    </div>

<div class="yiv7409233758moz-cite-prefix"><br>

    </div>

<div class="yiv7409233758moz-cite-prefix">On 3/28/22 14:46, Brian and Wendy
      Warrick wrote:<br>

    </div>

    <blockquote type="cite">
      
      <style type="text/css">#yiv7409233758 P {margin-top:0;margin-bottom:0;}</style>
      
<div style="font-family:Calibri, Helvetica, sans-serif;font-size:12pt;color:rgb(0, 0, 0);">
        Does anyone have a recommendation for a good quality garden hose
        that won't kink and last more than a couple of years? I need to
        replace one that was done at the end of last fall. I have one
        that is a seafoam green color with the word "contractor"
        imprinted on it, but I have been unable to find it online. I
        bought it at Costco probably 15 years ago and it has been a
        great hose.</div>

<div style="font-family:Calibri, Helvetica, sans-serif;font-size:12pt;color:rgb(0, 0, 0);">
        <br>

      </div>

<div style="font-family:Calibri, Helvetica, sans-serif;font-size:12pt;color:rgb(0, 0, 0);">
        Cost isn't really an issue. I am looking for good quality.</div>

<div style="font-family:Calibri, Helvetica, sans-serif;font-size:12pt;color:rgb(0, 0, 0);">
        <br>

      </div>

<div style="font-family:Calibri, Helvetica, sans-serif;font-size:12pt;color:rgb(0, 0, 0);">
        Thanks</div>

<div style="font-family:Calibri, Helvetica, sans-serif;font-size:12pt;color:rgb(0, 0, 0);">
        Brian Warrick</div>

<div style="font-family:Calibri, Helvetica, sans-serif;font-size:12pt;color:rgb(0, 0, 0);">
        Nampa, ID</div>

      <br>

      <fieldset class="yiv7409233758moz-mime-attachment-header"></fieldset>
      <pre class="yiv7409233758moz-quote-pre">_______________________________________________

<a rel="nofollow noopener noreferrer" ymailto="mailto:[email-masked]" target="_blank" href="mailto:[email-masked]" class="yiv7409233758moz-txt-link-abbreviated">[email-masked]</a>
Archive: <a rel="nofollow noopener noreferrer" target="_blank" href="http://www.team.net/pipermail/shop-talk" class="yiv7409233758moz-txt-link-freetext">http://www.team.net/pipermail/shop-talk</a> <a rel="nofollow noopener noreferrer" target="_blank" href="http://autox.team.net/archive" class="yiv7409233758moz-txt-link-freetext">http://autox.team.net/archive</a>

</pre>
    </blockquote>
    
<div><br>

    </div>

  </div>

</div>
_______________________________________________<br>
<br>
<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a><br>
Archive: <a href="http://www.team.net/pipermail/shop-talk" target="_blank">http://www.team.net/pipermail/shop-talk </a><a href="http://autox.team.net/archive" target="_blank">http://autox.team.net/archive</a><br>
<br>
<br>
</font></div>
</div>

------=_Part_1725976_1589295636.1656941600198--

--===============1200597134611036211==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________

[email-masked]
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

--===============1200597134611036211==--

---

From: Jeff Scarbrough <[email-masked]>
Date: Mon, 4 Jul 2022 11:09:10 -0400

We bought one of these last year.
https://www.amazon.com/gp/product/B08S6KGJ3Q  My spouse uses it on a
regular basis to water everything.  We don't even need a hose reel -
it is very light, and shrinks up to a manageable size.  Easily stored
in the garage out of the weather with all the other tools.

We use these couplers to quickly connect it to one of the outdoor taps
 https://www.amazon.com/gp/product/B00835N902   Bulletproof, and the
gaskets are available from Dixon to repair them if they start to leak
(uncommon).

I still have my hose reel for my 200 feet of Craftsman rubber hose,
which is going on 20 years old now.

If I could find a durable nozzle, I'd be in great shape.  So far, this
one has been the most satisfying, meaning it's lasted more than a
year:  https://www.amazon.com/gp/product/B08S6KGJ3Q

On Mon, Jul 4, 2022 at 9:47 AM DAVID MASSEY <[email-masked]> wrote:
>
> Hat's off to Jimmie for his recommendation of the Flexzilla hose.  I bought a 50 ft as a trial and the wife loved it so I bought a 100 ft hose for the other side of the house.
>
> They ain't cheap, though.  Is it worth it?  It depends.  If you drag the hose out once or twice a month to wash the car or hose off the patio, probably not.  But my wife is an avid gardener and she will use the hose every morning to water the potted plants, window boxes and other selected plants.  She loves it.  Much easier to drag around the yard and wind back up on the hose reel.
>
> Dave
> I can't speak for its longevity but I bought a 100ft Flexzilla hose about 4 years ago.  It's easily the most flexible garden hose I've ever used, even when pressurized.  It's not kink-proof but kinks...almost don't matter?  When my other two hoses kink I have to stop what I'm doing, walk over to the kink and manually untwist it.  But this hose is flexible enough that I just need to "flick" it like a whip and the kink usually undoes itself.
>
> I'm really tempted to buy one of those 4000psi Flexzilla pressure washer hoses this year.  I loathe having to wrestle with my current pressure washer hose...
>
> -- J
>
>
> Does anyone have a recommendation for a good quality garden hose that won't kink and last more than a couple of years? I need to replace one that was done at the end of last fall. I have one that is a seafoam green color with the word "contractor" imprinted on it, but I have been unable to find it online. I bought it at Costco probably 15 years ago and it has been a great hose.
>
> Cost isn't really an issue. I am looking for good quality.
>
> Thanks
> Brian Warrick
> Nampa, ID
>
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]
>
>
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]
>
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]
>

[email-masked]