Subject: Re: [Shop-talk] Good quality garden hose

From: [email-masked]
Date: Mon, 28 Mar 2022 15:24:11 -0400 (EDT)

Brian,

i have several Craftsman 100% rubber hoses that are more than 25 years old and have never had a problem.

Ron Olds

----- Original Message -----
From: "Brian and Wendy Warrick" <[email-masked]>
To: "shop-talk" <[email-masked]>
Sent: Monday, March 28, 2022 2:46:02 PM
Subject: [Shop-talk] Good quality garden hose

Does anyone have a recommendation for a good quality garden hose that won't kink and last more than a couple of years? I need to replace one that was done at the end of last fall. I have one that is a seafoam green color with the word "contractor" imprinted on it, but I have been unable to find it online. I bought it at Costco probably 15 years ago and it has been a great hose. 

Cost isn't really an issue. I am looking for good quality. 

Thanks 
Brian Warrick 
Nampa, ID 

_______________________________________________

[email-masked]
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

_______________________________________________

[email-masked]
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

---

From: Bob Spidell <[email-masked]>
Date: Mon, 28 Mar 2022 12:29:22 -0700

This is a multi-part message in MIME format.
--===============8271463291033967575==
 boundary="------------JNjt1vDHCV00xbyO8b9QP3hZ"
Content-Language: en-US

This is a multi-part message in MIME format.
--------------JNjt1vDHCV00xbyO8b9QP3hZ
Content-Transfer-Encoding: 7bit

IMO, rubber is the way to go (I have to drag several long hoses around 
to water a large yard). The plastic ones get stiff as <insert favorite 
analogy here> in the cold, kink easily and eventually crack. Rubber 
isn't perfect; it can kink if you abuse it and will eventually 
deteriorate, turning your hands black, but will work for a decade or 
more and the fittings are usually more robust. Unfortunately, as the 
plastic ones are so much cheaper--all some people care about--rubber 
hoses are getting harder to find, but I've bought several Craftsmen 
brand off Amazon over the years.

On 3/28/2022 11:46 AM, Brian and Wendy Warrick wrote:
> Does anyone have a recommendation for a good quality garden hose that 
> won't kink and last more than a couple of years? I need to replace one 
> that was done at the end of last fall. I have one that is a seafoam 
> green color with the word "contractor" imprinted on it, but I have 
> been unable to find it online. I bought it at Costco probably 15 years 
> ago and it has been a great hose.
>

--------------JNjt1vDHCV00xbyO8b9QP3hZ
Content-Transfer-Encoding: 7bit

<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  </head>
  <body>
    IMO, rubber is the way to go (I have to drag several long hoses
    around to water a large yard). The plastic ones get stiff as
    &lt;insert favorite analogy here&gt; in the cold, kink easily and
    eventually crack. Rubber isn't perfect; it can kink if you abuse it
    and will eventually deteriorate, turning your hands black, but will
    work for a decade or more and the fittings are usually more robust.
    Unfortunately, as the plastic ones are so much cheaper--all some
    people care about--rubber hoses are getting harder to find, but I've
    bought several Craftsmen brand off Amazon over the years.<br>
    <br>
    <br>
    <div class="moz-cite-prefix">On 3/28/2022 11:46 AM, Brian and Wendy
      Warrick wrote:<br>
    </div>
    <blockquote type="cite"
cite="mid:[email-masked]">
      <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
      <style type="text/css" style="display:none;">P {margin-top:0;margin-bottom:0;}</style>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        Does anyone have a recommendation for a good quality garden hose
        that won't kink and last more than a couple of years? I need to
        replace one that was done at the end of last fall. I have one
        that is a seafoam green color with the word "contractor"
        imprinted on it, but I have been unable to find it online. I
        bought it at Costco probably 15 years ago and it has been a
        great hose.</div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        <br>
      </div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        Cost isn't really an issue. I am looking for good quality.</div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        <br>
      </div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        Thanks</div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        Brian Warrick</div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        Nampa, ID</div>
      <br>
    </blockquote>
    <br>
  </body>
</html>

--------------JNjt1vDHCV00xbyO8b9QP3hZ--

--===============8271463291033967575==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============8271463291033967575==--

---

From: David Scheidt <[email-masked]>
Date: Mon, 28 Mar 2022 15:30:57 -0500

--===============6747677038805583948==
Content-Transfer-Encoding: 7bit

--Apple-Mail-2F1CC2B7-C1C4-4A41-B851-B911C66FE783
	charset=utf-8
Content-Transfer-Encoding: quoted-printable

> On Mar 28, 2022, at 13:46, Brian and Wendy Warrick <[email-masked]>=
 wrote:
> =EF=BB=BF
> Does anyone have a recommendation for a good quality garden hose that won'=
t kink and last more than a couple of years? I need to replace one that was d=
one at the end of last fall. I have one that is a seafoam green color with t=
he word "contractor" imprinted on it, but I have been unable to find it onli=
ne. I bought it at Costco probably 15 years ago and it has been a great hose=
.
>=20
>=20

Dramm sell good quality epdm hose with brass fittings. They are not cheap. I=
 don=E2=80=99t know if dramm makes the hose or if they=E2=80=99re reselling s=
omeone else=E2=80=99s.=20

--Apple-Mail-2F1CC2B7-C1C4-4A41-B851-B911C66FE783
	charset=utf-8
Content-Transfer-Encoding: quoted-printable

<html><head><meta http-equiv=3D"content-type" content=3D"text/html; charset=3D=
utf-8"></head><body dir=3D"auto"><div dir=3D"ltr"><div dir=3D"ltr"></div><di=
v dir=3D"ltr"><br></div><div dir=3D"ltr"><br><blockquote type=3D"cite">On Ma=
r 28, 2022, at 13:46, Brian and Wendy Warrick &lt;[email-masked]&gt; w=
rote:<br><br></blockquote></div><blockquote type=3D"cite"><div dir=3D"ltr">=EF=
=BB=BF

<meta http-equiv=3D"Content-Type" content=3D"text/html; charset=3Diso-8859-1=
">

<div style=3D"font-family: Calibri, Helvetica, sans-serif; font-size: 12pt; c=
olor: rgb(0, 0, 0);">
Does anyone have a recommendation for a good quality garden hose that won't k=
ink and last more than a couple of years? I need to replace one that was don=
e at the end of last fall. I have one that is a seafoam green color with the=
 word "contractor" imprinted
 on it, but I have been unable to find it online. I bought it at Costco prob=
ably 15 years ago and it has been a great hose.</div>
<div style=3D"font-family: Calibri, Helvetica, sans-serif; font-size: 12pt; c=
olor: rgb(0, 0, 0);">
<br>
</div>
<div style=3D"font-family: Calibri, Helvetica, sans-serif; font-size: 12pt; c=
olor: rgb(0, 0, 0);">
Cost isn't really an issue. I am looking for good quality.</div>
<div style=3D"font-family: Calibri, Helvetica, sans-serif; font-size: 12pt; c=
olor: rgb(0, 0, 0);"><br></div></div></blockquote><br><div>Dramm sell good q=
uality epdm hose with brass fittings. They are not cheap. I don=E2=80=99t kn=
ow if dramm makes the hose or if they=E2=80=99re reselling someone else=E2=80=
=99s.&nbsp;</div><div><br></div><div><br></div></div></body></html>=

--Apple-Mail-2F1CC2B7-C1C4-4A41-B851-B911C66FE783--

--===============6747677038805583948==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============6747677038805583948==--

---

From: Jimmie Mayfield <[email-masked]>
Date: Mon, 28 Mar 2022 17:28:13 -0400

This is a multi-part message in MIME format.
--===============1292969853604538421==
 boundary="------------W55yh3900uom6q2w0fV0arWg"
Content-Language: en-US

This is a multi-part message in MIME format.
--------------W55yh3900uom6q2w0fV0arWg
Content-Transfer-Encoding: 8bit

I can't speak for its longevity but I bought a 100ft Flexzilla hose 
about 4 years ago.  It's easily the most flexible garden hose I've ever 
used, even when pressurized. It's not kink-proof but kinks...almost 
don't matter?  When my other two hoses kink I have to stop what I'm 
doing, walk over to the kink and manually untwist it.  But this hose is 
flexible enough that I just need to "flick" it like a whip and the kink 
usually undoes itself.

I'm really tempted to buy one of those 4000psi Flexzilla pressure washer 
hoses this year.  I loathe having to wrestle with my current pressure 
washer hose...

-- J

On 3/28/22 14:46, Brian and Wendy Warrick wrote:
> Donate:http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Archive:http://www.team.net/pipermail/shop-talk  http://autox.team.net/archive
>
> Unsubscribe/Manage:http://autox.team.net/mailman/options/shop-talk/[email-masked]
>

--------------W55yh3900uom6q2w0fV0arWg
Content-Transfer-Encoding: 8bit

<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  </head>
  <body>
    <div class="moz-cite-prefix">I can't speak for its longevity but I
      bought a 100ft Flexzilla hose about 4 years ago.  It's easily the
      most flexible garden hose I've ever used, even when pressurized. 
      It's not kink-proof but kinks...almost don't matter?  When my
      other two hoses kink I have to stop what I'm doing, walk over to
      the kink and manually untwist it.  But this hose is flexible
      enough that I just need to "flick" it like a whip and the kink
      usually undoes itself.  <br>
    </div>
    <div class="moz-cite-prefix"><br>
    </div>
    <p>I'm really tempted to buy one of those 4000psi Flexzilla pressure
      washer hoses this year.  I loathe having to wrestle with my
      current pressure washer hose...</p>
    <div class="moz-cite-prefix"><br>
    </div>
    <div class="moz-cite-prefix">-- J<br>
    </div>
    <div class="moz-cite-prefix"><br>
    </div>
    <div class="moz-cite-prefix"><br>
    </div>
    <div class="moz-cite-prefix">On 3/28/22 14:46, Brian and Wendy
      Warrick wrote:<br>
    </div>
    <blockquote type="cite"
cite="mid:[email-masked]">
      <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
      <style type="text/css" style="display:none;">P {margin-top:0;margin-bottom:0;}</style>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        Does anyone have a recommendation for a good quality garden hose
        that won't kink and last more than a couple of years? I need to
        replace one that was done at the end of last fall. I have one
        that is a seafoam green color with the word "contractor"
        imprinted on it, but I have been unable to find it online. I
        bought it at Costco probably 15 years ago and it has been a
        great hose.</div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        <br>
      </div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        Cost isn't really an issue. I am looking for good quality.</div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        <br>
      </div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        Thanks</div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        Brian Warrick</div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        Nampa, ID</div>
      <br>
      <fieldset class="moz-mime-attachment-header"></fieldset>
      <pre class="moz-quote-pre" wrap="">_______________________________________________

<a class="moz-txt-link-abbreviated" href="mailto:[email-masked]">[email-masked]</a>
Archive: <a class="moz-txt-link-freetext" href="http://www.team.net/pipermail/shop-talk">http://www.team.net/pipermail/shop-talk</a> <a class="moz-txt-link-freetext" href="http://autox.team.net/archive">http://autox.team.net/archive</a>

</pre>
    </blockquote>
    <p><br>
    </p>
  </body>
</html>

--------------W55yh3900uom6q2w0fV0arWg--

--===============1292969853604538421==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============1292969853604538421==--

---

From: Jeff Scarbrough <[email-masked]>
Date: Mon, 28 Mar 2022 21:02:45 -0400

I have a couple of those Craftsman hoses, and they are in
astonishingly good condition after 15 years.  Probably can't buy the
like of them today, but we have bought some hoses at work that seem
equally durable, but they are incredibly heavy.  Can't remember the
brand, but they came from Grainger, I think.  Yellow in color...

On Mon, Mar 28, 2022 at 3:24 PM <[email-masked]> wrote:
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]
>

[email-masked]