Subject: [Shop-talk] Hand-held steam cleaner

From: [email-masked]
Date: Thu, 25 Feb 2021 22:48:44 -0800

While I have a small pressure washer, it is not always smart especially in our wet and rainy times
What I’m looking for is user experience with a small unit being used inside the shop 
I could catch the droppings on paper and still clean engine bays with the help of low pressure steam
Thought?
Super thanks 

Steve Hammatt 
Mount Vernon WA USA
Sent from my iPhone
_______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

---

From: [email-masked]
Date: Fri, 26 Feb 2021 07:02:47 -0500 02/26/2021 07:02:48 AM, Serialize complete at 02/26/2021 07:02:48 AM

This is a multipart message in MIME format.
--===============3134115731013706922==

This is a multipart message in MIME format.
--=_alternative 00422CB885258688_=
Content-Transfer-Encoding: base64

--=_alternative 00422CB885258688_=
Content-Transfer-Encoding: base64

--=_alternative 00422CB885258688_=--

--===============3134115731013706922==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============3134115731013706922==--