Subject: [Shop-talk] Question about 1/2" belt sander belts

From: [email-masked]
Date: Mon, 12 Oct 2020 16:30:37 -0400 9.0.1FP7|August 17, 2016) at 10/12/2020 04:30:37 PM, Serialize complete at 10/12/2020 04:30:37 PM, Serialize by Router on Deep13/Megageek(Release 9.0.1FP7|August 17, 2016) at 10/12/2020 04:30:38 PM

It's rare that a HF tool gets a second chance to impress me. But I have to say, the CHICAGO ELECTRIC 1/2" Belt Sander did just that, but left me with a new problem.
https://www.harborfreight.com/53-amp-12-in-heavy-duty-bandfile-belt-sander-62863.html

I started a new 'sideline' of products to sell. They are customize products made with old scuba tanks.

So I needed a way to dress up the 1/2" thick edges of the cut tanks. Some die grinding discs made for AL do the trick, but it still needs a sanding.

I tried paper, sponges, and other methods. The AL grabs an rips most of these. For grins, I tried the 1/2" belt sander I got a while ago but never used it because it was a bit of a disappointment.

Well, it works AWESOME for doing this. It's quick and easy. HOWEVER, the issue is that the tape on the belts quickly fails long before the belt's sanding ability is worn.

I tried every tape here I can find to repair the belts with no luck. The tape needs to be ultra tacky and strong, while not stretchable and the glue has to hold when it gets warm.
So my question is three fold.

1-Does anyone know of a source of really good belts for this sander other than the HF ones? HF no longer has a store brand and just have the 'Baxter' and 'Warrior' brands which I think might just be the same quality.

2-Is there a tape I can use to fix these belts that will last longer?

3-Is there another way to sand an edge of a AL SCUBA tank I should try?

Bonus question-
Anyone have any clever names for such a line of tanks? I was thinking of "Tanks for the Memories" but I was wondering if anyone else had any better ideas.

Note, I am making bells, mailboxes, TP holders, lamps, and a bunch of other items out of the tanks.

"Tanks" in advance

"Be as beneficent as the sun or the sea, but if your rights as a rational being are trenched on, die on the first inch of your territory." Ralph Waldo Emerson -Who is John Galt?
_______________________________________________

[email-masked]
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

---

From: Pat Horne <[email-masked]>
Date: Mon, 12 Oct 2020 16:41:49 -0500

Is tgere a wider belt of the same length? If so you could try slitting the wide belts into narrower ones. 

There is an industrial belt company that I’ve used for decades. Klingspor. Check them out. First glance shows 1/2” belts but 60” long. They may have something you can use. 

Peace,
Pat

Pat Horne 
We support Habitat for Humanity

On Oct 12, 2020, at 4:33 PM, [email-masked] wrote:

DING DING DING-

Bob s came in with the winning answer up front.

The flap disk worked great (although it got pretty beat up.)

So now I have to order a ton of them!

Also, I love the name suggestion!

Note- I am still looking for better belts for the sander as there are small edges that I can't get with a flap sander.

I should have stated that I tried most of the 'fixes' on the web also. Glues and tevex etc.

the 1/2" belts are so narrow that nothing seems to work on them however.

Thanks again!

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]