Subject: [Shop-talk] Looking to buy a compressor

From: Darrell Walker <[email-masked]>
Date: Fri, 7 Aug 2020 14:21:45 -0700

I’m in the market for a compressor.  I’m looking for about 10 CFM at 90 psi.

I actually have an Eastwood scroll compressor on backorder, but I’m getting anxious, and thinking about other things to spend the price difference on.  I do like that the scroll compressor is very quiet, though.

I’ve looked at four possibilities, all much cheaper than the Eastwood:

	Husky 60 gallon (from Home Depot)
	Kobalt 60 gallon (from Lowes)
	Puma PK-6060 (from Amazon)
	Campbell Hausfeld VT6195 (from Grizzly)

The Husky and Kobalt are very close in price, the Puma and CH are a bit more.

The Kobalt is dual-stage, the rest are single stage (but dual cylinder), but all meet my expected air requirements.

I believe the Kobalt is made by CH, though it is not the same as the CH model I’m looking at.

Any experience or comments on any of these choices?  Anything else I ought to look at in a similar range?

Thanks,
Darrell

-- 
Darrell Walker
66 TR4A IRS-SC CTC67956L
81 TR8 SATPZ458XBA406206
Vancouver, WA, USA

_______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

---

From: Pat Horne <[email-masked]>
Date: Thu, 13 Aug 2020 11:54:50 -0500

I need to make some changes to my air lines @ the compressor to add an intercooler between the compressor & tank. 

I have a 60 gallon 11 CFM compressor outside that feeds a 1”x12” drip leg w/valve that then feeds 1” copper pipe in the ceiling. It runs up hill for 40’ across the shop. Each of my air outlets is fed from the main line. I drain the drip leg every few days & the compressor daily when working. I need to add an automatic drain one of these days. 

When I am doing a bunch of blasting the air @ the cabinet is about 110°. A local separator takes care of the rest of the moisture. 

Peace,
Pat

Pat Horne 
We support Habitat for Humanity

On Aug 13, 2020, at 11:27 AM, Ronnie Day <[email-masked]> wrote:

Unless this is a large, complex system, I think the simplest and effective way to deal with moisture in the piping is iron piping with drip stems with ball valves on the ends and a moisture separator near each air outlet, and each outlet needs to be stubbed off of a vertical  pipe section. I just google air system pipe layout and that many layouts, most using this basic idea.

FWIW

[email-masked]

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]