Subject: Re: [Shop-talk] Weber Kettle rotisserie?

From: DAVID MASSEY <[email-masked]>
Date: Wed, 12 Aug 2020 11:47:12 +0000 (UTC)

--===============4656525359449254038==
	boundary="----=_Part_573464_1561667919.1597232832488"

------=_Part_573464_1561667919.1597232832488
Content-Transfer-Encoding: quoted-printable

 I'm on my second 22 inch Weber in 49 years.=C2=A0 Those things are bullet =
proof.=C2=A0=20

I guess it is a question of how often you will use it.=C2=A0 If the answer =
is "infrequently" then I think you can get similar results grilling over in=
direct heat with frequent turning.=C2=A0 It is more work but not too bad.
But then, there is always the cool factor.=C2=A0 ;-)
=20
Dave=20

=20
=20
-----Original Message-----
From: Mark J Bradakis <[email-masked]>
To: [email-masked] <[email-masked]>
Sent: Tue, Aug 11, 2020 7:06 pm
Subject: [Shop-talk] Weber Kettle rotisserie?

I really like my 22" Weber Kettle charcoal grill. Lately I've been=20
wondering whether or not it would be worth it to get a rotisserie=20
adapter for it? It's basically a ring the size of the kettle that fits=20
on top of it, and the lid fits on top of that. It has a big skewer, a=20
couple of rotisserie forks and an electric motor.

I've made it to this point in my grilling life without one, is it=20
actually worth spending money on it? Any real life experience?

https://youtu.be/ozzUParaBlk

mjb.

_______________________________________________

[email-masked]
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/arch=
ive

[email-masked]

------=_Part_573464_1561667919.1597232832488
Content-Transfer-Encoding: 7bit

<div style="color:black;font: 12pt Arial, Helvetica, sans-serif;">
<div> <font size="3">I'm on my second 22 inch Weber in 49 years.&nbsp; Those things are bullet proof.&nbsp; <br>
</font></div>

<div><font size="3"><br>
</font></div>

<div><font size="3">I guess it is a question of how often you will use it.&nbsp; If the answer is "infrequently" then I think you can get similar results grilling over indirect heat with frequent turning.&nbsp; It is more work but not too bad.</font></div>

<div><font size="3"><br>
</font></div>

<div><font size="3">But then, there is always the cool factor.&nbsp; ;-)</font><br>
</div>

<div> <br>
</div>

<div style="clear:both"><font size="4">Dave </font><br>
<br>
</div>

<div> <br>
</div>

<div> <br>
</div>

<div style="font-family:arial,helvetica;font-size:10pt;color:black">-----Original Message-----<br>
From: Mark J Bradakis &lt;[email-masked]&gt;<br>
To: [email-masked] &lt;[email-masked]&gt;<br>
Sent: Tue, Aug 11, 2020 7:06 pm<br>
Subject: [Shop-talk] Weber Kettle rotisserie?<br>
<br>

<div dir="ltr">I really like my 22" Weber Kettle charcoal grill. Lately I've been <br>
</div>

<div dir="ltr">wondering whether or not it would be worth it to get a rotisserie <br>
</div>

<div dir="ltr">adapter for it? It's basically a ring the size of the kettle that fits <br>
</div>

<div dir="ltr">on top of it, and the lid fits on top of that. It has a big skewer, a <br>
</div>

<div dir="ltr">couple of rotisserie forks and an electric motor.<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">I've made it to this point in my grilling life without one, is it <br>
</div>

<div dir="ltr">actually worth spending money on it? Any real life experience?<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr"><a href="https://youtu.be/ozzUParaBlk" target="_blank">https://youtu.be/ozzUParaBlk</a><br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">mjb.<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">_______________________________________________<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr"><a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a><br>
</div>

<div dir="ltr">Donate: <a href="http://www.team.net/donate.html" target="_blank">http://www.team.net/donate.html</a><br>
</div>

<div dir="ltr">Suggested annual donation&nbsp; $12.96<br>
</div>

<div dir="ltr">Archive: <a href="http://www.team.net/pipermail/shop-talk" target="_blank">http://www.team.net/pipermail/shop-talk </a><a href="http://autox.team.net/archive" target="_blank">http://autox.team.net/archive</a><br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">Unsubscribe/Manage: <a href="http://autox.team.net/mailman/options/shop-talk/[email-masked]" target="_blank">http://autox.team.net/mailman/options/shop-talk/[email-masked]</a><br>
</div>

<div dir="ltr"><br>
</div>
</div>
</div>

------=_Part_573464_1561667919.1597232832488--

--===============4656525359449254038==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________

[email-masked]
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

--===============4656525359449254038==--

---

From: Jeff Scarbrough <[email-masked]>
Date: Wed, 12 Aug 2020 11:34:05 -0400

--===============0682329544049445500==

--0000000000009f6f7305acafebab

On Wed, Aug 12, 2020 at 7:47 AM DAVID MASSEY <[email-masked]> wrote:

> I'm on my second 22 inch Weber in 49 years.  Those things are bullet
> proof.
>

I've never ruined a Smokey Joe, just had them stolen.

> I guess it is a question of how often you will use it.  If the answer is
> "infrequently" then I think you can get similar results grilling over
> indirect heat with frequent turning.  It is more work but not too bad.
>

I thought the whole point of outdoor cooking is to sit and watch the fire
while drinking beer and occasionally flipping something over.   If you're
sitting in the air conditioning, watching your food on a wireless
thermometer, you ain't doing it right.

--0000000000009f6f7305acafebab
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr"><div dir=3D"ltr"><br></div><br><div class=3D"gmail_quote">=
<div dir=3D"ltr" class=3D"gmail_attr">On Wed, Aug 12, 2020 at 7:47 AM DAVID=
 MASSEY &lt;<a href=3D"mailto:[email-masked]">[email-masked]</a>&gt=
; wrote:<br></div><blockquote class=3D"gmail_quote" style=3D"margin:0px 0px=
 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
<div style=3D"color:black;font:12pt Arial,Helvetica,sans-serif">
<div> <font size=3D"3">I&#39;m on my second 22 inch Weber in 49 years.=C2=
=A0 Those things are bullet proof.=C2=A0 <br></font></div></div></blockquot=
e><div><br></div><div>I&#39;ve never ruined a Smokey Joe, just had them sto=
len.</div><div>=C2=A0</div><blockquote class=3D"gmail_quote" style=3D"margi=
n:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex=
"><div style=3D"color:black;font:12pt Arial,Helvetica,sans-serif"><div><fon=
t size=3D"3">
</font></div>

<div><span style=3D"font-size:medium">I guess it is a question of how often=
 you will use it.=C2=A0 If the answer is &quot;infrequently&quot; then I th=
ink you can get similar results grilling over indirect heat with frequent t=
urning.=C2=A0 It is more work but not too bad.</span><br></div>

<div><font size=3D"3"></font></div></div></blockquote><div><br></div><div>I=
 thought the whole point of outdoor cooking is to sit and watch the fire wh=
ile drinking beer and occasionally flipping something=C2=A0over.=C2=A0 =C2=
=A0If you&#39;re sitting in the=C2=A0air conditioning, watching your food o=
n a wireless thermometer, you ain&#39;t doing it right.</div></div></div>

--0000000000009f6f7305acafebab--

--===============0682329544049445500==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============0682329544049445500==--

---

From: DAVID MASSEY <[email-masked]>
Date: Wed, 12 Aug 2020 16:33:53 +0000 (UTC)

--===============6960747020145279307==
	boundary="----=_Part_686488_1681619233.1597250033917"

------=_Part_686488_1681619233.1597250033917
Content-Transfer-Encoding: quoted-printable

 I replaced mine only because I wanted the new features (specifically the a=
sh removal).
=20
Dave=20

=20
=20
-----Original Message-----
From: Jeff Scarbrough <[email-masked]>
To: [email-masked] <[email-masked]>
Sent: Wed, Aug 12, 2020 10:34 am
Subject: Re: [Shop-talk] Weber Kettle rotisserie?

I've never ruined a Smokey Joe, just had them stolen.=C2=A0
I guess it is a question of how often you will use it.=C2=A0 If the answer =
is "infrequently" then I think you can get similar results grilling over in=
direct heat with frequent turning.=C2=A0 It is more work but not too bad.

I thought the whole point of outdoor cooking is to sit and watch the fire w=
hile drinking beer and occasionally flipping something=C2=A0over.=C2=A0 =C2=
=A0If you're sitting in the=C2=A0air conditioning, watching your food on a =
wireless thermometer, you ain't doing it right.____________________________=
___________________

[email-masked]

[email-masked]

------=_Part_686488_1681619233.1597250033917
Content-Transfer-Encoding: 7bit

<div style="color:black;font: 12pt Arial, Helvetica, sans-serif;">
<div> <font size="3">I replaced mine only because I wanted the new features (specifically the ash removal).</font><br>
</div>

<div> <br>
</div>

<div> <br>
</div>

<div> <br>
</div>

<div style="font-family:arial,helvetica;font-size:10pt;color:black">-----Original Message-----<br>
From: Jeff Scarbrough &lt;[email-masked]&gt;<br>
To: [email-masked] &lt;[email-masked]&gt;<br>
Sent: Wed, Aug 12, 2020 10:34 am<br>
Subject: Re: [Shop-talk] Weber Kettle rotisserie?<br>
<br>

<div id="yiv0827764506">
<div>
<div dir="ltr">
<div dir="ltr"><br clear="none"></div>
<br clear="none">
<div class="yiv0827764506gmail_quote">
<div class="yiv0827764506gmail_attr" dir="ltr">On Wed, Aug 12, 2020 at 7:47 AM DAVID MASSEY &lt;<a rel="nofollow" shape="rect" ymailto="mailto:[email-masked]" target="_blank" href="mailto:[email-masked]">[email-masked]</a>&gt; wrote:<br clear="none"></div>
<blockquote class="yiv0827764506gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex;">

<div style="color:black;font:12pt Arial, Helvetica, sans-serif;">

<div> <font size="3">I'm on my second 22 inch Weber in 49 years.&nbsp; Those things are bullet proof.&nbsp; <br clear="none"></font></div>
</div>
</blockquote>
<div><br clear="none"></div>

<div>I've never ruined a Smokey Joe, just had them stolen.</div>

<div class="yiv0827764506yqt7338307808" id="yiv0827764506yqtfd59321">
<div>&nbsp;</div>
</div>
<blockquote class="yiv0827764506gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex;">
<div style="color:black;font:12pt Arial, Helvetica, sans-serif;">
<div class="yiv0827764506yqt7338307808" id="yiv0827764506yqtfd55933">
<div><font size="3">
</font></div>

</div>

<div>
<div class="yiv0827764506yqt7338307808" id="yiv0827764506yqtfd02280"><span style="font-size:medium;">I guess it is a question of how often you will use it.&nbsp; If the answer is "infrequently" then I think you can get similar results grilling over indirect heat with frequent turning.&nbsp; It is more work but not too bad.</span></div>
<br clear="none"></div>

<div><font size="3"></font></div>
</div>
</blockquote>
<div><br clear="none"></div>

<div>I thought the whole point of outdoor cooking is to sit and watch the fire while drinking beer and occasionally flipping something&nbsp;over.&nbsp; &nbsp;If you're sitting in the&nbsp;air conditioning, watching your food on a wireless thermometer, you ain't doing it right.</div>
</div>
</div>
</div>
</div>

<div class="yqt7338307808" id="yqtfd93681">_______________________________________________<br clear="none"><br clear="none"><a shape="rect" ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a><br clear="none">Donate: <a shape="rect" href="http://www.team.net/donate.html" target="_blank">http://www.team.net/donate.html</a><br clear="none">Suggested annual donation&nbsp; $12.96<br clear="none">Archive: <a shape="rect" href="http://www.team.net/pipermail/shop-talk" target="_blank">http://www.team.net/pipermail/shop-talk </a><a shape="rect" href="http://autox.team.net/archive" target="_blank">http://autox.team.net/archive</a><br clear="none"><br clear="none">Unsubscribe/Manage: <a shape="rect" href="http://autox.team.net/mailman/options/shop-talk/[email-masked]" target="_blank">http://autox.team.net/mailman/options/shop-talk/[email-masked]</a><br clear="none"><br clear="none"></div>
</div>
</div>

------=_Part_686488_1681619233.1597250033917--

--===============6960747020145279307==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============6960747020145279307==--