Subject: [Shop-talk] Charcoal. was: who knows......

From: Mark Miller via Shop-talk <[email-masked]>
Date: Fri, 8 May 2020 15:45:20 -0700

I'm a big fan of Lazzari mesquite lump charcoal.  Might be only local 
(SF area), though.
http://www.lazzari.com/

Regards,

Mark Miller   707-490-5834
[email-masked]

_______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

---

From: Mark J Bradakis via Shop-talk <[email-masked]>
Date: Fri, 8 May 2020 19:00:33 -0600

> I'm a big fan of Lazzari mesquite lump charcoal.  Might be only local 

A big ol' ribeye grilled over rocket hot mesquite is quite a tasty 
treat.  But mesquite can be tricky, and give some unpleasant flavors if 
over used.  I'll have to check out these guys, maybe it's available in Utah.

mjb.

[email-masked]

---

From: Jack Brooks via Shop-talk <[email-masked]>
Date: Tue, 12 May 2020 21:13:17 +0000

Here in the PNW Lazzari, one of my favorites also, is carried by "Cash and Carry" now also known as "Smart Foodservice".  Great lump charcoal and reasonably priced. 

Jack

-----Original Message-----
From: Shop-talk <[email-masked]> On Behalf Of Mark Miller via Shop-talk
Sent: Friday, May 8, 2020 3:45 PM
To: [email-masked]
Subject: [Shop-talk] Charcoal. was: who knows......

I'm a big fan of Lazzari mesquite lump charcoal.  Might be only local (SF area), though.
http://www.lazzari.com/

Regards,

Mark Miller   707-490-5834

[email-masked]

Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]