Subject: Re: [Shop-talk] Speedometer angle drive

From: Eric Russell via Shop-talk <[email-masked]>
Date: Tue, 24 Sep 2019 22:45:53 -0400

I don't know if he'll have what you seek but Morris at West Valley 
Instruments has been very good about responding to my email inquiries.

https://www.westvalleyinstruments.com/

Eric Russell
Mebane, NC

On 9/24/2019 9:50 PM, Robert Nogueirao via Shop-talk wrote:
> Anyone know a small shop that can supply a Smiths type speedometer angle drive?

_______________________________________________

[email-masked]
Archive: http://www.team.net/pipermail/shop-talk http://autox.team.net/archive

---

From: Robert Nogueirao via Shop-talk <[email-masked]>
Date: Wed, 25 Sep 2019 21:14:58 -0500

Eric, thank you for the recommendation to contact Morris. I called and he called right back and is going to modify a new angle drive to fit my needs.
Bob Nogueira 

> On Sep 24, 2019, at 9:45 PM, Eric Russell via Shop-talk <[email-masked]> wrote:
> 
> I don't know if he'll have what you seek but Morris at West Valley Instruments has been very good about responding to my email inquiries.
> 
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]
> 

[email-masked]