Subject: [Shop-talk] Have you built your own house?

From: Jim Franklin <[email-masked]>
Date: Wed, 27 Jul 2016 08:44:19 -0400

I'm toying with doing this, mostly myself. I've done a few big projects like dormers, full remodels, so I'm not green. I'm mostly curious in what you thought about the experience and the result, and would you do it again. I have read Norm Abrahms' book (which is a fun read if you haven't) as well as House by Tracy Kidder. 

thanks,
jim
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Pat Horne <[email-masked]>
Date: Sun, 31 Jul 2016 07:39:13 -0500

Jim,
Building your own house is certainly possible. I've built quite a few as a house lead working with Habitat for Humanity.  I know that leading a house construction is different from doing it yourself, but it will give you an idea. I also built my shop with the help of a couple friends. 

There are several things to consider. 
How complex is your house? The more complex, the longer it will take to build it. 

How sure you will have the conviction to stick with the project through completion? The Habitat houses I build take up to 4000 man hours to build for about 1100 sq.ft. 

How are you planning to find the construction? Most banks will not fund a construction loan only if the project is built by a construction company with required licenses & insurance.  

I'll be glad to discuss any other points you are concerned about. 

Peace,
Pat

Pat Horne 
We support Caldwell County Habitat for Humanity

On Jul 27, 2016, at 7:44 AM, Jim Franklin <[email-masked]> wrote:

thanks,
jim

[email-masked]

[email-masked]