Subject: [Shop-talk] Fixing LCD TVs

From: Jim Franklin <[email-masked]>
Date: Sun, 1 May 2016 17:42:06 -0400

According to shopjimmy.com (parts purveyor) this isn't too hard. I have a "free" LCD that the picture suddenly went out on while in use. Reportedly still had sound, but since the sound input source is menu driven, and I can't see the menu, I have not yet been able to have it spit out sound.

The above webpage says if you can see the menu display in a dark room with a flashlight pointed at the screen, the problem is the inverter board. I replaced it for $40 and...no change. So now I'm thinking it's the power supply to that board.

The low voltage cabe tests fine. There's a high voltage line with no specs so I can't test it. But there's a capacitor right next to the transformers that looks like this:

http://groupwbench.org/InsigniaCap.JPG

Is that blown, or just poorly covered?

The power supply is out of stock, probably permanently. 

jim
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Sun, 1 May 2016 22:02:39 -0700

> The low voltage cabe tests fine. There's a high voltage line 
> with no specs so I can't test it. But there's a capacitor 
> right next to the transformers that looks like this:
> 

Sure looks busted to me!  Unfortunately, it probably took some other components with it.

I've seen a couple of designs lately for ESR testers; that usually claim they can be used in-circuit.  Eg,
http://www.ebay.com/itm/Anatek-Blue-ESR-Capacitor-Tester-Meter-Complete-Kit-for-Assy-/252151208911?hash=item3ab5621bcf:g:ErUAAOxydgZ
TJ77b

-- Randall  

[email-masked]