Subject: [Shop-talk] How NOT to buff a REALLY sharp knife

From: [email-masked]
Date: Thu, 18 Feb 2016 08:41:11 -0500 02/18/2016 08:41:12, Serialize complete at 02/18/2016 08:41:12

This is a multipart message in MIME format.
--===============6386633441804282128==

This is a multipart message in MIME format.
--=_alternative 004DD9BB85257F5D_=

OK, I'm looking for suggestions on how to SAFELY buff metal objects (like 
knives.)

I started making knives.  So I bought a really nice 3/4HP Baldor buffer. 
I've used buffers like this before, normally BEFORE the knife has been 
sharpened.  However, I was redoing the handle on  a knife I already 
sharpened.  Let's just say, 'things got away from me.'

11 stitches later, I'm looking for suggestions.  I need a way to hold the 
blade edge of a knife when working on it. In the past, I've taped the 
edge, but this was so sharp, it wouldn't have helped.

I've searched online, but I can't find anything to help.  I was thinking 
of a wooden 'sheath' like clamp to put the blade in.

Any Ideas?

BTW, if you want to see photos (or you want help losing our appetite, here 
are a few photos of the damage.)  Note, I didn't drop the knife!

http://tinyurl.com/thumbouch 

Thanks in advance

Sent from my Commodore 64 on a 2400 Baud Modem.
Eric P
"Be as beneficent as the sun or the sea, but if your rights as a rational 
being are trenched on, die on the first inch of your territory." Ralph 
Waldo Emerson 
--=_alternative 004DD9BB85257F5D_=

<font size=2 face="sans-serif">OK, I'm looking for suggestions on how
to SAFELY buff metal objects (like knives.)</font>
<br>
<br><font size=2 face="sans-serif">I started making knives. &nbsp;So I
bought a really nice 3/4HP Baldor buffer. &nbsp;I've used buffers like
this before, normally BEFORE the knife has been sharpened. &nbsp;However,
I was redoing the handle on &nbsp;a knife I already sharpened. &nbsp;Let's
just say, 'things got away from me.'</font>
<br>
<br><font size=2 face="sans-serif">11 stitches later, I'm looking for suggestions.
&nbsp;I need a way to hold the blade edge of a knife when working on it.
In the past, I've taped the edge, but this was so sharp, it wouldn't have
helped.</font>
<br>
<br><font size=2 face="sans-serif">I've searched online, but I can't find
anything to help. &nbsp;I was thinking of a wooden 'sheath' like clamp
to put the blade in.</font>
<br><font size=2 face="sans-serif"><br>
Any Ideas?</font>
<br>
<br><font size=2 face="sans-serif">BTW, if you want to see photos (or you
want help losing our appetite, here are a few photos of the damage.) &nbsp;Note,
I didn't drop the knife!</font>
<br>
<br><a href=http://tinyurl.com/thumbouch><font size=1 color=blue face="Verdana"><b>http://tinyurl.com/thumbouch</b></font></a><font size=3>
</font>
<br><font size=2 face="sans-serif"><br>
Thanks in advance</font>
<br>
<br><font size=2 face="sans-serif"><br>
Sent from my Commodore 64 on a 2400 Baud Modem.<br>
Eric P<br>
&quot;Be as beneficent as the sun or the sea, but if your rights as a rational
being are trenched on, die on the first inch of your territory.&quot; Ralph
Waldo Emerson </font>
--=_alternative 004DD9BB85257F5D_=--

--===============6386633441804282128==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

--===============6386633441804282128==--

---

From: Jimmie Mayfield <[email-masked]>
Date: Thu, 18 Feb 2016 15:17:21 -0500

This is a multi-part message in MIME format.
--===============1943439965700563275==
 boundary="------------040507090303040602020407"

This is a multi-part message in MIME format.
--------------040507090303040602020407
Content-Transfer-Encoding: 7bit

Hi.  My pole saw blade has a stout leather scabbard.  Perhaps you could 
hack together something similar using rawhide?

Image here: 
http://www.americantreeservicesupply.com/files/2443767/uploaded/Extended%20Reach%20Pole%20Saw%20Blade%20Scabbard1.jpg

On 02/18/2016 08:41 AM, [email-masked] wrote:
> OK, I'm looking for suggestions on how to SAFELY buff metal objects 
> (like knives.)
>
> I started making knives.  So I bought a really nice 3/4HP Baldor 
> buffer.  I've used buffers like this before, normally BEFORE the knife 
> has been sharpened.  However, I was redoing the handle on  a knife I 
> already sharpened.  Let's just say, 'things got away from me.'
>
> 11 stitches later, I'm looking for suggestions.  I need a way to hold 
> the blade edge of a knife when working on it. In the past, I've taped 
> the edge, but this was so sharp, it wouldn't have helped.
>
> I've searched online, but I can't find anything to help.  I was 
> thinking of a wooden 'sheath' like clamp to put the blade in.
>

--------------040507090303040602020407
Content-Transfer-Encoding: 8bit

<html>
  <head>
    <meta content="text/html; charset=windows-1252"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div class="moz-cite-prefix">Hi.  My pole saw blade has a stout
      leather scabbard.  Perhaps you could hack together something
      similar using rawhide?<br>
      <br>
      Image here:
<a class="moz-txt-link-freetext" href="http://www.americantreeservicesupply.com/files/2443767/uploaded/Extended%20Reach%20Pole%20Saw%20Blade%20Scabbard1.jpg">http://www.americantreeservicesupply.com/files/2443767/uploaded/Extended%20Reach%20Pole%20Saw%20Blade%20Scabbard1.jpg</a><br>
      <br>
      <br>
      <br>
      On 02/18/2016 08:41 AM, <a class="moz-txt-link-abbreviated" href="mailto:[email-masked]">[email-masked]</a> wrote:<br>
    </div>
    <blockquote
cite="mid:[email-masked]"
      type="cite"><font face="sans-serif" size="2">OK, I'm looking for
        suggestions on how
        to SAFELY buff metal objects (like knives.)</font>
      <br>
      <br>
      <font face="sans-serif" size="2">I started making knives.  So I
        bought a really nice 3/4HP Baldor buffer.  I've used buffers
        like
        this before, normally BEFORE the knife has been sharpened.
         However,
        I was redoing the handle on  a knife I already sharpened.  Let's
        just say, 'things got away from me.'</font>
      <br>
      <br>
      <font face="sans-serif" size="2">11 stitches later, I'm looking
        for suggestions.
         I need a way to hold the blade edge of a knife when working on
        it.
        In the past, I've taped the edge, but this was so sharp, it
        wouldn't have
        helped.</font>
      <br>
      <br>
      <font face="sans-serif" size="2">I've searched online, but I can't
        find
        anything to help.  I was thinking of a wooden 'sheath' like
        clamp
        to put the blade in.</font>
      <br>
      <font face="sans-serif" size="2"></font><br>
    </blockquote>
    <br>
  </body>
</html>

--------------040507090303040602020407--

--===============1943439965700563275==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============1943439965700563275==--