Subject: [Shop-talk] new project need mechanical advice

From: "john niolon" <[email-masked]>
Date: Sat, 12 Dec 2015 21:28:20 -0600

Had an opportunity to pick this up... couldn't pass it up..
.
1985 Mercedes Benz 380 SE got a 4.7L FI engine double overhead cam... I think

been sitting up probably 10 years... they tried to start it in b13 or b14
...no luck... probably bad gas...

anyway... it's sitting in MY yard now with the battery on charge. I need
someone with Mercedes experience I guess and the dealer wants 2nd mortgage
money

If you were going to try to get it running after sitting so long... what would
you do and in what sequence... I figure drain the gas, change the oil... talk
to me

http://jniolon.classicpickup.com/Img_0790.jpg
http://jniolon.classicpickup.com/Img_0785.jpg

I figure change plugs, figure out where the fuel filter is and remove it...
pull injectors and clean them
get the fuel out of the tank and the fuel rails then replace filter
change the oil  (sticker says last change 2004)

what else ???
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Sat, 12 Dec 2015 19:58:26 -0800

After adding fresh oil and you pull the plugs, squirt a healthy dose of your favorite penetrating oil (eg PB Blaster or Kroil) into
each plug hole.  Let sit for a few hours, then spin the engine with the plugs out.

After changing fuel and removing injectors, run the pump long enough to flush out the lines with fresh fuel.  Check for water in
what comes out.

I don't know how the engine is arranged, but if it doesn't fire quickly, I'd look for some way to verify that both cams are turning.

-- Randall  

[email-masked]