Subject: [Shop-talk] Buying a new compressor of just the 'compressor'?

From: [email-masked]
Date: Wed, 25 Nov 2015 09:07:27 -0500 7.0.1|January 17, 2006) at 11/25/2015 09:07:30, Serialize complete at 11/25/2015 09:07:30

First, Happy T'day to all the US folk here.  For your not in the US, have 
a great day as well.

On to the question...

I have a compressor that I have been using for about 20 years now (wow, 
has it really been that long?)

Recently, the compressor is leaking some oil.  So I know a replacement is 
coming up.  My question, is it better to replace the whole unit, or just 
the compressor pump?

I was leaning to the whole unit just to avoid any issues with rusted 
tanks, etc.  Also, I could sell the old one to someone who really needs 
one and is willing to take the time to fix it for a low price.

So, if you were buying a new compressor, what one would you go for under 
$2000?  (240v of course.)

Thanks.

Sent from my Commodore 64 on a 2400 Baud Modem.
Eric P
"Be as beneficent as the sun or the sea, but if your rights as a rational 
being are trenched on, die on the first inch of your territory." Ralph 
Waldo Emerson 
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Bill Gilroy <[email-masked]>
Date: Wed, 25 Nov 2015 13:35:02 -0500 FILETIME=[01F6E4A0:01D127B0]

I would get the whole unit.  I think you are in NJ, plenty of moisture in the
air.  I have heard good thing about Eaton's,
https://www.eatoncompressor.com/piston-compressors/industrial-series-5-10-hp

But I do not have any personal experience with them.

Sent from Outlook Mail<http://go.microsoft.com/fwlink/?LinkId=550987> for
Windows 10 phone

From: [email-masked]
Sent: Wednesday, November 25, 2015 9:35 AM
To: [email-masked]
Subject: [Shop-talk] Buying a new compressor of just the 'compressor'?

On to the question...

Thanks.

[email-masked]
Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/shop-talk/[email-masked]
_______________________________________________

[email-masked]

---

From: "Randall" <[email-masked]>
Date: Wed, 25 Nov 2015 16:12:35 -0800

> My question, is it better to replace the whole 
> unit, or just 
> the compressor pump?

Even here in relatively dry southern California, my last (cheap) compressor tank rusted through and started leaking before the
compressor packed it in.  At one point I also had the pressure control switch malfunction and leave the compressor running; plus the
pop-off valve didn't do it's job (apparently full of wasp's nest).  Probably lucky it didn't explode, but the single stage
compressor would only go so high.  The PRV sure screamed a long time after I touched it, though!  So if you're looking to go another
20 years, my suggestion would be to replace all of it.

> So, if you were buying a new compressor, what one would you 

Ingersoll-Rand is the "gold standard" for air compressors IMO.  I'd find an IR model that suits your needs and go with that.  The
one I use was made by IR, but sold by Sears.  It's probably 20 years old by now (I bought it used) and still going strong, but I
don't use it all that much.

-- Randall  

[email-masked]