Subject: [Shop-talk] hydraulic oil filters

From: "john niolon" <[email-masked]>
Date: Wed, 18 Nov 2015 14:06:31 -0600

well itbs time to change hydraulic fluid on my ZTR...  Gravely zt hd52.
Ibm planning on going full synthetic .   itbs what Gravely recommends...
of course they recommend THEIR filters, but Ibm partial to Wix or Napa gold
or platinum for all my oil filters... but Ibm not up on hydraulic stuff
(itbs all oil but itbs different, isnbt it ??)

any recommendations on brands ...   they spec a 25 micron filter on theirs.
Itbs a 5K lawnmower and I donbt want to cheap out on a filter...  not
looking for a FRAM or  Walmart substitute...

tia

john
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Jeff Scarbrough <[email-masked]>
Date: Thu, 19 Nov 2015 10:57:59 -0500

Putting on my engineering hat:  What's the expected cost of a
substitute filter?  Looks like the correct filter is available for $15
or less, including shipping.  Is your anticipated savings worth taking
a chance of the incorrect filter spec?

Jeff Scarbrough
Corrosion Acres, Ga.

On Wed, Nov 18, 2015 at 3:06 PM, john niolon <[email-masked]> wrote:
> well itb s time to change hydraulic fluid on my ZTR...  Gravely zt hd52.
> Ib m planning on going full synthetic .   itb s what Gravely recommends...
> of course they recommend THEIR filters, but Ib m partial to Wix or Napa gold
> or platinum for all my oil filters... but Ib m not up on hydraulic stuff
> (itb s all oil but itb s different, isnb t it ??)
>
> Itb s a 5K lawnmower and I donb t want to cheap out on a filter...  not
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]