Subject: [Shop-talk] Halogen replacement bulbs

From: Brad Kahler <[email-masked]>
Date: Mon, 9 Feb 2015 19:47:16 -0500

I give up.  I've been buying replacement halogen bulbs from Harbor Freight
and it seems the more I buy the faster they burn out.  The last two bulbs I
installed burned out within 4 hours and during that time I didn't move the
light once.  NOT acceptable!

Any suggestions on where I can buy good quality replacement bulbs for a
reasonable price?

Thanks!

Brad
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Tue, 10 Feb 2015 10:54:23 -0800

> This appears to be the flood lamp replacement LED blub.  
> Definitely pricey
> at $27 but if it lasts at least 27 times longer the cost 
> could easily be
> justified.  Depending one other responses to my query I might 
> give it a try.
> 
> https://www.superbrightleds.com/moreinfo/led-tube/8w-r7s-led-f
loodlight-replacement-lamp/1192/2808/

Perhaps I am confused about what we are talking about?  That thing only puts out 700 lumens or so, less than a 60 watt incandescent.

I assumed the question was about those 500 watt halogen "sticks" that put out over 10 times as much light.  Eg,
http://tinyurl.com/nasolzq

Sorry, I can't help with how long they last.  I only have them in a some shop lights that I almost never use.

Just a thought though: High power bare LED "pucks" are pretty cheap if you buy them in bulk on flea-bay.  For example, here is
10,000 lumens worth for $12.
http://tinyurl.com/mk6e5tm
Too soon to say how long it will last, but so far I've had good luck using JB Weld to secure them to a heavy aluminum plate as a
heat sink.  Of course then you'll need a suitable power supply, but the Internet is full of designs.  Here's one that is
transformerless (ie cheap) and I think should be fairly easily scaled for higher current LEDs.
http://downloads.deusm.com/designnews/20121126-LED-DESK-LAMP.pdf

-- Randall  

[email-masked]