Subject: Re: [Shop-talk] Disc brake piston explosion

From: "Tim ." <[email-masked]>
Date: Sun, 25 Jan 2015 21:34:12 -0600

Any ideas what caused it?

"F350 pick up."

sorry. couldn't resist.
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: John Miller <[email-masked]>
Date: Sun, 25 Jan 2015 19:48:25 -0800

> Any ideas what caused it?

Are they steel pistons?

Ford tried phenolic-resin pistons in several applications a while back, 
and they were notorious for coming apart in heavy use.

But it would surprise me a LOT if Ford went down that road in something 
like an F350.

John.

[email-masked]