Subject: Re: [Shop-talk] who makes a good press?

From: Dave Cavanaugh <[email-masked]>
Date: Sat, 13 Dec 2014 18:06:37 -0800

Dake is made in the USA; professional grade presses, with a price to match.

On 12/13/2014 5:41 PM, Tim . wrote:
>   I am looking for a good American made press. I am a clueless but always
> learning amateur in my shop and the time has come to get a press.
>
> The boss wants to get this for me for Christmas but I told her I will find out
> who makes a good one and then she can get me a gift cert.
>
> Thanks
>
> tim
> _______________________________________________
>
> [email-masked]
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: "Tim ." <[email-masked]>
Date: Sat, 13 Dec 2014 20:26:47 -0600

"with a price to match." ....if you can find one I guess.

Am aware of Dake. But one looks at their web site and cannot see/get prices. I
really hate that.

> Date: Sat, 13 Dec 2014 18:06:37 -0800
> From: [email-masked]
> To: [email-masked]
> Subject: Re: [Shop-talk] who makes a good press?
>

[email-masked]

---

From: Mark J Bradakis <[email-masked]>
Date: Sat, 13 Dec 2014 20:26:15 -0700

This may take me a while. I remember a few years back looking for a tubing bender to do roll bar
fabrication at Bailey's shop. As I recall one company also had some press frames. If I remember
I'll post.

And on a totally unrelated note I may be posting some hand tools and such for sale as I continue to
slowly work on cleaning up the garage.

mjb.

[email-masked]

---

From: Dave Cavanaugh <[email-masked]>
Date: Sat, 13 Dec 2014 19:44:48 -0800

They probably don't sell direct.

Google "Dake hydraulic press" and then click on the "shopping" tab.

[email-masked]

---

From: "Steve Hammatt, Mount Vernon WA USA" <[email-masked]>
Date: Sun, 14 Dec 2014 08:26:15 -0800

Funny you should ask.  Ibm selling my 15 ton Wagner (US Made)
press.  Itbs used but decent shape.  Moving after 34 years and the
new shop will be much smaller than the one I now have (2k sq ft).
Looking for $200 if you can pick up (Itbs broken apart for easy
transfer).  Now, if only you lived in the northwest part of the NorthWest!
Garage sale next Sunday....

Steve Hammatt
Mount Vernon WA USA

From: Tim .
Sent: Saturday, December 13, 2014 5:41 PM
To: Shop Talk
Subject: [Shop-talk] who makes a good press?

The boss wants to get this for me for Christmas but I told her I will find
out
who makes a good one and then she can get me a gift cert.

Thanks

tim

[email-masked]
Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/shop-talk/[email-masked]

-----
No virus found in this message.
Checked by AVG - www.avg.com
Version: 2014.0.4794 / Virus Database: 4235/8731 - Release Date: 12/13/14
_______________________________________________

[email-masked]