Subject: Re: [Shop-talk] The air compressor to have now

From: Ronnie Day <[email-masked]>
Date: Sun, 23 Nov 2014 14:10:39 -0600

TP Tools has some good info on their site, and their products looks pretty
good. You might check out autobodyshop.com, too. That said, I'd determine
what I need then look at Home Depot, Lowes and Northern Tools, if there's
one near you. Compare prices and warranties. In this case, I think a big
box store is good for long term, local service, And I expect the prices to
be good due to volume of sales.

You're very likely to get the best prices next weekend.

Ron

On Sunday, November 23, 2014, Scott <[email-masked]> wrote:

> It's time for a new compressor. I also want it to be the last one I buy.
>
> I remember the last time I did this (maybe ten, fifteen years ago), it was
> an Ingersoll Rand T-something. T-10, T-55, I thought it was similarly named
> to a Russian tank, for some reason.
>
> Anyway, If you were buying one today, which would it be? I've got the
> space for anything, and I'd like to never even have to think about running
> out of air again. Not running a shop, but I'll paint with it, and run a
> blast cabinet with it.
>
> Thanks guys.
> _______________________________________________
>
> [email-masked]
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/
> options/shop-talk/[email-masked]
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Scott <[email-masked]>
Date: Sun, 23 Nov 2014 17:33:54 -0500

I probably should have been more specific:

I'm looking for a two-stage, 220v, at least 60-gallon-tank (and really 
that's 80 gallons unless there's something about the 60 that's ideal, 
and bigger-than-80 would be nice).

I remember that a specific model of I-R was the favorite back when I 
couldn't justify the purchase. Now I can, so I'm upgrading.

On 11/23/2014 3:10 PM, Ronnie Day wrote:
> TP Tools has some good info on their site, and their products looks 
> pretty good. You might check out autobodyshop.com 
> <http://autobodyshop.com>, too. That said, I'd determine what I need 
> then look at Home Depot, Lowes and Northern Tools, if there's one near 
> you. Compare prices and warranties. In this case, I think a big box 
> store is good for long term, local service, And I expect the prices to 
> On Sunday, November 23, 2014, Scott <[email-masked] 
>
>     I remember the last time I did this (maybe ten, fifteen years
>     ago), it was an Ingersoll Rand T-something. T-10, T-55, I thought
>     it was similarly named to a Russian tank, for some reason.
>
>     Anyway, If you were buying one today, which would it be? I've got
>     the space for anything, and I'd like to never even have to think
>     about running out of air again. Not running a shop, but I'll paint
>     with it, and run a blast cabinet with it.
>
>     Thanks guys.

[email-masked]

---

From: old dirtbeard <[email-masked]>
Date: Sun, 23 Nov 2014 18:17:26 -0800

This is "the best" two stage 7.5 HP compressor on the market:

http://www.pacificaircompressors.com/compressor-champion-HRV7-8-1P.htm

I am just waiting for mine to die so I can justify buying it.

The key is that it has a pump that only runs at 575 RPM (.e.g., a nice thump, thump, thump like a Gold Star on low idle) driven by a quality 31 amp Baldor motor running at 1725 RPM.

It outputs 26 CFM, but it is the same pump that is used on the much larger compressors except that the pump runs slower for the 7.5 HP motor.  The pump and motor really should run forever (just compare the pump speeds on comparable compressors).
 
best,

doug
________________
'72 BSA B50SS
'74 Moto Guzzi 850T

'01 HD XHL 883
'03 GMC Cargo Van
'07 Aprilia SXV 550
'13 Aprilia Tuono V4R

________________________________
 From: Scott <[email-masked]>
To: Shop Talk List <[email-masked]> 
Sent: Sunday, November 23, 2014 2:33 PM
Subject: Re: [Shop-talk] The air compressor to have now

[email-masked]

[email-masked]

---

From: Mark J Bradakis <[email-masked]>
Date: Sun, 23 Nov 2014 23:41:15 -0700

I was thinking my big one was an IR, but I just looked, it is a Devilbiss Pro 4000, 60 gallon unit.
I've been happy with it, it served me well for many years.  I don't have 220 in the garage so I have
not run it since I moved out of the shop some years ago. I should make sure it still works someday.
Maybe a long extension cord from the 220 box that feed the A/C compressor.

mjb.

[email-masked]

---

From: David Scheidt <[email-masked]>
Date: Mon, 24 Nov 2014 20:28:17 -0600

> and bigger-than-80 would be nice).

There's no reason not to get an 80 gallon tank except for money or
space restrictions,
in a shop where you're going to have intermittent high demand.  If
you're in an industrial
setting, with a defined constant load, smaller tanks make sense.

Champion and Quincy are the two companies that seem to be still making
top quality stuff in the US.  IRs quality has apparently taken a dip.
A shop I used to run had a 7.5 HP champion, and two 5 HP quincy pumps
(built or rebuilt by a local shop on different tanks, one of those may
have been something else, and just looked like the quincy.).  One of
the 5HP was lead pump, the 7.5 cut in if pressure dropped below
something (120?) and the other 5HP came in as lag if the pressure fell
further (and then took over as lead).  We had problems with the
control electronics and the automatic drains, but not with the pumps.
(the big air consumer there was the car wash, which had an incredible
demand.)

If you want one that will last for ever, get a pressure lubricated
pump, and run it at the lowest speed and pressure possible.

-- 
David Scheidt
[email-masked]

[email-masked]