Subject: [Shop-talk] GE profile Dishwasher

From: john Mitchell <[email-masked]>
Date: Wed, 05 Nov 2014 19:46:41 -0500

I have a GE profile dishwasher that's about 5 years old.   I find 
it's not getting the dishes as clean as it used to.  Does anyone have 
any suggestions of where to start looking for the problem? Everything 
appears to be spinning inside.  Thanks for any ideas. John Mitchell
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Randall <[email-masked]>
Date: Thu, 6 Nov 2014 1:38:21 +0000

---- john Mitchell <[email-masked]> wrote: 
> appears to be spinning inside.  

Have you cleaned all the screens and water jets?  On my old Kitchenaid, the little jets in the arm for the upper rack would frequently get clogged, as well as the screens at the bottom.

Randall

[email-masked]

---

From: "Randall" <[email-masked]>
Date: Thu, 6 Nov 2014 08:09:57 -0800

> What would be the best way to clean them out?

On my Kitchen Aid, there were larger openings on the ends of the arm.  So to clean the smaller openings along the length, I usually
just poked a wooden toothpick through the hole and let the blob of food get flushed out the larger opening.  (The KA is gone now,
and so far I've not had any problems with the Bosch replacement.)

It's also worthwhile occasionally running a cycle with a generous dollop of (cheap) white vinegar and no dishes.  Or if you prefer,
a product like CLR.

Randall

[email-masked]