Subject: Re: [Shop-talk] GE profile Dishwasher

From: Doug Braun <[email-masked]>
Date: Wed, 5 Nov 2014 20:38:12 -0500

Check if any of the little holes in the rotating arms are clogged.

Doug

On Nov 5, 2014 8:09 PM, "john Mitchell" <[email-masked]> wrote:
>
>   I have a GE profile dishwasher that's about 5 years old.   I find it's
not getting the dishes as clean as it used to.  Does anyone have any
suggestions of where to start looking for the problem? Everything appears
to be spinning inside.  Thanks for any ideas. John Mitchell
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Darrell Walker <[email-masked]>
Date: Wed, 05 Nov 2014 17:54:15 -0800

Check that all the jets in the spray bars are clear.

-Darrell

> On Nov 5, 2014, at 4:46 PM, john Mitchell <[email-masked]> wrote:
>
>  I have a GE profile dishwasher that's about 5 years old.   I find it's not
getting the dishes as clean as it used to.  Does anyone have any suggestions
of where to start looking for the problem? Everything appears to be spinning
inside.  Thanks for any ideas. John Mitchell
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/shop-talk/[email-masked]
_______________________________________________

[email-masked]

---

From: john Mitchell <[email-masked]>
Date: Wed, 05 Nov 2014 21:03:39 -0500

What would be the best way to clean them out?
On 11/5/2014 8:38 PM, Doug Braun wrote:
> On Nov 5, 2014 8:09 PM, "john Mitchell" <[email-masked] 
> >
> >   I have a GE profile dishwasher that's about 5 years old.  I find 
> it's not getting the dishes as clean as it used to. Does anyone have 
> any suggestions of where to start looking for the problem? Everything 
> appears to be spinning inside.  Thanks for any ideas. John Mitchell

[email-masked]

---

From: Jeff Scarbrough <[email-masked]>
Date: Thu, 6 Nov 2014 08:25:17 -0500

The arm and screen should all be easily removable.  Then use a small
pick and some vinegar to clean out all the clog, backflushing the arm.

On Wed, Nov 5, 2014 at 9:03 PM, john Mitchell <[email-masked]> wrote:
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]

---

From: David Scheidt <[email-masked]>
Date: Thu, 6 Nov 2014 08:38:19 -0600

> What would be the best way to clean them out?

Some arms are snapped together, and can be pried apart and put back together.

Also check the screens for the pump(s).  stuff builds up on tem, and
restrict flow.

-- 
David Scheidt
[email-masked]

[email-masked]