Subject: [Shop-talk] aerosol cans

From: "Tim ." <[email-masked]>
Date: Sat, 27 Sep 2014 10:35:22 -0500 FILETIME=[A6EBA9F0:01CFDA68]

I have a bunch of cans, PB blaster, WD40, etc that have lost their pressure
but are not empty; a couple are close to half full. (I left these two in them
garage shop over winter <insert embarrassed emoticon here>)

I am wondering if anyone has punched open cans in this condition to salvage
the rest of the penetrant/contents? If so, what has been done or recommended?
Or should I not even mess with it?

I have a seized block I'd love to use these cans' contents on....

thanks
tim
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Sat, 27 Sep 2014 09:04:59 -0700

> I have a bunch of cans, PB blaster, WD40, etc that have lost 

What I usually do is re-pressurize them from the shop air.  Takes a certain amount of coordination, but I hold the tip of the
(non-OSHA) air gun up to the opening of the spray button, then press the button while pressing the valve on the air gun.  You may
need to repeat a few times as you empty the can (especially if the can was still nearly full) but it gives a good spray for a while.

> the rest of the penetrant/contents? 

I've done that too.  The neat way is to drill a hole, but a prick punch & BFH works well enough.

In fact, I'm in the habit of piercing cans before I throw them away; just to remove any possibility of the can exploding when the
garbage is compacted.  For that, a sharp rap on the corner of the vise will usually puncture the can.  They are surprisingly thin.

Randall

[email-masked]