Subject: [Shop-talk] A mini drill press that doesn't suck?

From: Doug Braun <[email-masked]>
Date: Thu, 11 Sep 2014 13:49:45 -0400

Hello,

I have a cheapo benchtop mini drill press that cost maybe $69.95.
It is sized right for my workbench, but it has an AC motor that stalls
easily, and
the quill is very sloppy, so the drill bit can jiggle side-to-side about
1/16".

Does anybody know if there is a source for a better model?  ALL the ones I
have ever seen in
stores, etc. are made in China, and their precision seems to be pretty
random- the display model could have a quill with no slop, but then the one
I bring home could be much worse.

And I have never seen a drill press that had the equivalent of gibs, which
would let me adjust away the slop.

I'd love to get a mini-mill to use instead, but those need at least 36" of
bench width, which I simply don't have.

Thanks,

Doug
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Randall <[email-masked]>
Date: Thu, 11 Sep 2014 20:34:58 +0000

> bench width, which I simply don't have.

How about a Sherline mill head (which I believe they will sell separately) attached to the column of your existing press?

Otherwise, I would ignore country of origin and instead look for a reputable maker.  Not everything made in China is junk.

Delta has apparently quit making their benchtop press, but I still see models from Jet and Rockwell.  They should be pretty good, even if they are from China.

Another thought would be looking into your existing press and see if it can be improved.  Maybe you can add shims to the fit between the quill and the housing; or even cut some tapered slots and add gibs.

Randall

[email-masked]