Subject: Re: [Shop-talk] Need help identifying a car manufacture's logo

From: [email-masked]
Date: Sun, 24 Aug 2014 22:45:42 -0400

I have a book published in 1970 titled "Car Badges of the World". I found
nothing like yours. The closest was from a Skoda.

> I have this hub cap and I can't figure out what it comes from.  I never
> saw this logo before (I don't even know if it is the right side up.)
>
> Its says "Eaton" inside the cap.
>
> Click here to see the photo...
>
> http://tinyurl.com/idhubcap
>
> Any help would be greatly appreciated!  Thanks!
>
>
> Eric P
> "Be as beneficent as the sun or the sea, but if your rights as a rational
> being are trenched on, die on the first inch of your territory." Ralph
> Waldo Emerson
> _______________________________________________
>
> [email-masked]
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/shop-talk/[email-masked]
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Miq Millman <[email-masked]>
Date: Sun, 24 Aug 2014 22:25:20 -0700

rotate it 90 counter clockwise and it could be the emblem for Lada

http://ausmalbilder-malvorlagen.org/ausmalbilder/autos/lada.jpg

--
__
Miq Millman   [email-masked]
Tualatin, OR  Big Llama Productions

On Sun, Aug 24, 2014 at 5:27 PM, <[email-masked]> wrote:

> http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]

---

From: Paul Parkanzky <[email-masked]>
Date: Mon, 25 Aug 2014 22:21:57 -0400

I'm on a forum with a bunch of folks that you can always count on to be an
automotive encyclopedia.  I had my answer in 45 minutes:

"i think its a Kaiser Darrin hubcap

https://www.google.com/search?q=kais...2F%3B640%3B640
<https://www.google.com/search?q=kaiser+darrin+hubcap&client=ubuntu&hs=k46&sa
=X&channel=fs&tbm=isch&imgil=fW1v3kcUTOAYRM%253A%253BjOFoXVjF9HlJAM%253Bhttps
%25253A%25252F%25252Fwww.flickr.com%25252Fphotos%25252Fmarkmorgantrinidad%252
52F9439113167%25252F&source=iu&usg=__tysxLDX36YB5MPXZcEWqd_MbcHc%3D&ei=Kaj6U5
jPAYuOyAT534GwAQ&ved=0CCAQ9QEwAA&biw=1834&bih=905#facrc=_&imgdii=_&imgrc=fW1v
3kcUTOAYRM%253A%3BjOFoXVjF9HlJAM%3Bhttps%253A%252F%252Fc2.staticflickr.com%25
2F6%252F5505%252F9439113167_4b2c61c950_z.jpg%3Bhttps%253A%252F%252Fwww.flickr
.com%252Fphotos%252Fmarkmorgantrinidad%252F9439113167%252F%3B640%3B640>

See post 344"

What's amazing is that post 344 is a post where someone had taken
photographs of a Darrin and they were discussing it.  Small world!

-Paul

On Sun, Aug 24, 2014 at 8:27 PM, <[email-masked]> wrote:

> http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]

---

From: Doug Braun <[email-masked]>
Date: Mon, 25 Aug 2014 22:44:57 -0400

Interesting!  But why did they pick such a strange, ugly logo?

Doug

[email-masked]