Subject: Re: [Shop-talk] dual side draft weber carbs

From: Jim Stone <[email-masked]>
Date: Sun, 19 May 2013 16:45:27 -0400

Rootes put DCOE 40's on a UK version of the fastback Sunbeam Alpine/Rapier in
the early 70's. you could probably find some photos by Googling "Sunbeam H120"
which was the Holbay engine designation. I know they were also used on Alfas
of the same vintage. That was probably much more widely available. I had them
on my Alpine for a while and loved them, but I never got them properly
synchronized or jetted and gave up after about 6 months. I later realized that
my manifold was defective and will one day try again. They were a blast!

Sent from my iPhone

On May 19, 2013, at 4:20 PM, "Tim" <[email-masked]> wrote:

> Can someone please tell me what cars commonly ran these carbs?
>
> I need to find detailed pictures of the linkage set up that uses the
> long bar across the top.
>
> Shop content....I am installin a set of these carbs on my Roadster in my
> shop.
>
> Thanks
> tim
> _______________________________________________
>
> [email-masked]
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/shop-talk/[email-masked]
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Mark J Bradakis <[email-masked]>
Date: Sun, 19 May 2013 15:01:40 -0600

Lotus used Webers or the very similar Dellorto carbs on many of their cars,
such as the Elan.

mjb.

[email-masked]

---

From: Ronnie Day <[email-masked]>
Date: Sun, 19 May 2013 20:58:21 -0500

Check out Pierce Manifolds (http://www.piercemanifolds.com/) for pretty
much anything Weber related.

On Sun, May 19, 2013 at 4:01 PM, Mark J Bradakis <[email-masked]> wrote:

> ______________________________**_________________
>
> [email-masked]
> Donate: http://www.team.net/donate.**html<http://www.team.net/donate.html>
> Unsubscribe/Manage: http://autox.team.net/mailman/**
> options/shop-talk/ronnie.day@**gmail.com<http://autox.team.net/mailman/options/shop-talk/[email-masked]>

[email-masked]