Subject: Re: [Shop-talk] "Rebuild kit" for Milwaukee 18V battery

From: Mark J Bradakis <[email-masked]>
Date: Mon, 11 Mar 2013 19:47:26 -0600

Interesting.  I have a few dead Craftsman 19.2 V packs that would be 
nice to save.
I'll have to poke around.

mjb.
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Scott <[email-masked]>
Date: Mon, 11 Mar 2013 21:46:43 -0400

Please do. I've got at least six (and maybe eight) Milwaukee 18v packs 
in the house. So many (and so dead) that I've started to lose track of them.

On 3/11/2013 9:38 PM, Lee Daniels wrote:
> Recalling discussions here on replacing the actual NiCd cells in a cordless
> tool battery, I came across a "rebuild kit" for my Milwaukee 18V battery. See
> here:
>    http://amzn.com/B008NETIIU
> At $43.50 this is a lot better price than I could get on a replacement battery
> - even the off-brand replacements. The reviews are very good for this item;
> I'll try to remember to "review" it here once I've received it and tried it
> out.

[email-masked]

---

From: "Lee Daniels" <[email-masked]>
Date: Wed, 13 Mar 2013 12:09:59 -0500

These same guys (Spring Grove Battery) have rebuild kits for several other
batteries too: Dewalt 14.4V, Milwaukee 14.4V, Dewalt 12V. See
http://goo.gl/mGbF0
And even more listed at their web site: http://www.springgrovebattery.com/

[email-masked]

---

From: Justin Bedard <[email-masked]>
Date: Wed, 13 Mar 2013 15:09:34 -0400

I haven't used them, but I've heard good things.  These guys rebuild the
batteries for you for and at least the Milwaukee 18v NiCAD rebuild is $48.75
vs $43.50 plus shipping your batteries out.

On Wed, Mar 13, 2013 at 1:09 PM, Lee Daniels <[email-masked]> wrote:

> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]