Subject: Re: [Shop-talk] Hazard Fraught Tools

From: Dave C <[email-masked]>
Date: Fri, 14 Sep 2012 19:55:22 -0700

I think I saw the dreidel in a recent Lee Valley catalog.   Or maybe 
Garrett Wade.

On 9/14/2012 4:53 AM, Tim wrote:
> Brilliant! I need that nail unbender!
>
>
> On Fri, Sep 14, 2012 at 6:42 AM, Jeff Scarbrough wrote:
>
>> Might be off-topic, or might just be good for a laugh.
>>
>> http://www.garagejournal.com/forum/showthread.php?t=146306
>>
>> I know I've bought some of those...
>> _______________________________________________
> _______________________________________________
>
> [email-masked]
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/shop-talk/[email-masked]
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: "Karl Vacek" <[email-masked]>
Date: Sat, 15 Sep 2012 09:03:25 -0500

Excellent - best laugh of the month at least.  Gotta read all the fine print
too - it's hysterical.

Having spent my high school and college years poring over the Warshawsky
catalog (J.C. Whitney if you're not from Chicago), this brilliant piece
makes me realize that Harbor Freight catalogs have taken their place in the
galaxy of time wasters.
_______________________________________________

[email-masked]