Subject: Re: [Shop-talk] Tall sturdy pull down stairs?

From: Wayne <[email-masked]>
Date: Sat, 25 Aug 2012 11:29:51 -0400

I was shopping for attic ladders recently. Werner has one that's 
supposed to be good for up to 12' ceilings and 375lbs.
http://us.wernerco.com/products/climbing-equipment/attic-ladders
Maybe not something stocked locally. Try Lowes or Amazon online?

-wayne

On 8/25/2012 11:03 AM, Jim Franklin wrote:
> Surprisingly I don't see anything in the archives about this..
>
> I have a garage ceiling that's 11'3 from finished floor to (soon to be)
> finished floor. I'd like a set of sturdy pull down stairs that can span this
> height and carry a 300lb load. Have you used anything you like?
>
> thanks,
> _______________________________________________
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Ronnie Day <[email-masked]>
Date: Sat, 25 Aug 2012 11:11:46 -0500

You really can't go wrong with Werner.

Ron
On Aug 25, 2012 10:31 AM, "Wayne" <[email-masked]> wrote:

> I was shopping for attic ladders recently. Werner has one that's supposed
> to be good for up to 12' ceilings and 375lbs.
> http://us.wernerco.com/**products/climbing-equipment/**attic-ladders<http://us.wernerco.com/products/climbing-equipment/attic-ladders>
>> ______________________________**_________________
>>
> ______________________________**_________________
>
> [email-masked]
> Donate: http://www.team.net/donate.**html<http://www.team.net/donate.html>
> Suggested annual donation  $12.96
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/**
> options/shop-talk/ronnie.day@**gmail.com<http://autox.team.net/mailman/options/shop-talk/[email-masked]>

[email-masked]

---

From: "Galt, Stuart A" <[email-masked]>
Date: Sat, 25 Aug 2012 09:47:46 -0700

Hmm, is there a solution out there for a bit taller?  My ceiling height is
13'8"

Stuart

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Wayne
Sent: Saturday, August 25, 2012 8:30 AM
To: Jim Franklin; Shop Talk List
Subject: Re: [Shop-talk] Tall sturdy pull down stairs?

I was shopping for attic ladders recently. Werner has one that's supposed to
be good for up to 12' ceilings and 375lbs.
http://us.wernerco.com/products/climbing-equipment/attic-ladders
Maybe not something stocked locally. Try Lowes or Amazon online?

-wayne

On 8/25/2012 11:03 AM, Jim Franklin wrote:
> I have a garage ceiling that's 11'3 from finished floor to (soon to
> be) finished floor. I'd like a set of sturdy pull down stairs that can
> span this height and carry a 300lb load. Have you used anything you like?
>
> thanks,

[email-masked]
Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/shop-talk/[email-masked]
_______________________________________________

[email-masked]

---

From: "Eric J Russell" <[email-masked]>
Date: Sat, 25 Aug 2012 15:45:33 -0400 a=QQn5ppE0i9YA:10 a=P2oOn6vrs4wA:10 a=8nJEP1OIZ-IA:10 a=6WxjnRXeafkA:10 a=wJjgFq53tGJlaoXvjQHWgA==:17 a=JBLUpSMPAAAA:8 a=2-KQy7HYAAAA:8 a=8GN4XRofAAAA:8 a=zOoktvdPAAAA:8 a=-jO5ufA7AAAA:8 a=xwPayol1AAAA:8 a=8ltF_vOb3Mrl1NMNSFAA:9 a=wPNLvfGTeEIA:10 a=J0aUVQLP0FIA:10 a=m3MdUl94G8cA:10 a=ZmW_8LdBKvYA:10 a=6PFYuX4-dlIA:10 a=FibliMNvKBIA:10 a=0Ob1RWNGeVAA:10 a=wJjgFq53tGJlaoXvjQHWgA==:117 reip=0.000, cl=1, cld=1, fgs=0

If the attic access is not something you will need often, you can make a 
simple platform to place on the floor such that the bottom of a slightly 
shorter pull down stair can rest upon it. I did this in our pre-remodeled 
garage. I had a ~ 3' X 3' box made of 2X12's & plywood. I marked the 
location on the garage floor with a few paint stripes.

Eric Russell
Mebane, NC

----- Original Message ----- 
From: "Galt, Stuart A" <[email-masked]>
To: "Wayne" <[email-masked]>; "Jim Franklin" <[email-masked]>; 
"Shop Talk List" <[email-masked]>
Sent: Saturday, August 25, 2012 12:47 PM
Subject: Re: [Shop-talk] Tall sturdy pull down stairs?

> to
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage:
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]

---

From: Rush <[email-masked]>
Date: Sun, 26 Aug 2012 21:38:22 -0400

These guys have models up to 11' 6" 
http://www.rainbowatticstair.com/attic-stairs-products/prestige-folding-attic-stairs.cfm

Jon

[email-masked]