Subject: Re: [Shop-talk] Repairing a fiberglass maul handle

From: Tim <[email-masked]>
Date: Mon, 28 May 2012 16:02:24 -0400 (EDT)

JB Weld?

On Mon, May 28, 2012 at 9:17 AM, [email-masked] wrote:

> OK, I bought a HD maul with a fiberglass handle.  I've used it for 
> over 20 cords of wood already in the past 2 years.  Here is a link to 
> it on their site...
>
>>
> 
> http://www.homedepot.com/h_d1/N-5yc1v/R-100387771/h_d2/ProductDisplay?catalogId=10053&langId=-1&keyword=maul&storeId=10051 
> <
>
> As the reviews will tell you, they separate at the top.  Now, its not 
> really broken, just separated.  Does anyone know of any kind of epoxy 
> that I could use on it?
>
> The fit is still good, in fact I split about another 1/8 of a cord 
> after it broke yesterday just by putting it back on after every 4th or 
> 5th log.
>
> Any ideas?  TIA
>
> Eric P
> "Be as beneficent as the sun or the sea, but if your rights as a 
> rational being are trenched on, die on the first inch of your 
> territory." Ralph Waldo Emerson 
> _______________________________________________
>
> [email-masked]
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/shop-talk/[email-masked]
_______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

---

From: "Jack Brooks" <[email-masked]>
Date: Mon, 28 May 2012 15:34:20 -0700

Slow cure marine epoxy.  You want slow cure because it'll cure stronger and
you want a flexible epoxy, or it'll break again.

Jack

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Tim
Sent: Monday, May 28, 2012 1:02 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Shop-talk] Repairing a fiberglass maul handle

JB Weld?

> over 20 cords of wood already in the past 2 years.  Here is a link to 
http://www.homedepot.com/h_d1/N-5yc1v/R-100387771/h_d2/ProductDisplay?catalo
gId=10053&langId=-1&keyword=maul&storeId=10051 

[email-masked]
http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]