Subject: [Shop-talk] Pressure Washer

From: Shannah Miller <[email-masked]>
Date: Mon, 23 Apr 2012 15:26:26 -0700

Hi,

I would like to do something nice for my uncle, who is
getting on in years, and has a TON of pressure washing
to do around his house.

I'm not looking for the cheap solution: does anyone have
any suggestion for a really GOOD power washer?  If it
has the ability to use solutions, in addition to just water,
that would be great.  If I can shop online and have it
shipped, more the better.

What pressure washer would you get if it was going to
be yours or a gift to a loved one?

Thanks for any suggestions,

Shannah
_______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.96
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

---

From: "Randall" <[email-masked]>
Date: Mon, 23 Apr 2012 16:09:45 -0700

> If it
> that would be great.

I don't have a suggestion, just something to watch for.  The pressure washer
I got had the "solution" input and even came with a gallon of soap.  What I
didn't realize before buying is that it will not pick up the solution when
in "high pressure" mode.  It will only suck the soap when the outlet is
opened up.

-- Randall 

[email-masked]

---

From: "battmain" <[email-masked]>
Date: Mon, 23 Apr 2012 23:37:17 +0000

Suggest at least 2500psi or better. Anything less has just annoyed me when I used it. Even with that amount of power, the rotating turbo nozzle is needed for the moldy sidewalks by me otherwise the job takes twice as long. Pricewise, you can get the units for 399 and up. 

B

Sent from my BlackBerry

-----Original Message-----
From: Shannah Miller <[email-masked]>
Sender: [email-masked]
Date: Mon, 23 Apr 2012 15:26:26 
To: ShopTalk<[email-masked]>
Subject: [Shop-talk] Pressure Washer

Hi,

Shannah

[email-masked]
Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]

---

From: Brian Kemp <[email-masked]>
Date: Mon, 23 Apr 2012 21:25:15 -0700

Randall - That is how mine is too.  I thought that is how they all 
worked.  You spray on the desired solution at low pressure and let is 
soak in then switch to high to actually clean and rinse.  It lets you 
wash then rinse a section at a time without having to make changes to 
the pressure washer.  I can see this feature being really handy if you 
are doing a house while on a ladder.

Brian

On 4/23/2012 4:09 PM, Randall wrote:
> Unsubscribe/Manage: http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]

---

From: Shannah Miller <[email-masked]>
Date: Tue, 24 Apr 2012 09:25:44 -0700

I found this one, that seems to fit the bill, in terms of having
enough pressure, and the ability to use detergent in addition
to the clean water spray.

Simpson Megashot MSH3125-S 3,100 PSI Honda GC190 Premium Gas Powered
Heavy Duty Pressure Washer

Anyone have any better suggestions?  If not, this is the one
I'm going to get for my uncle.  Thank you so much for your
input!

Shannah

On Mon, Apr 23, 2012 at 9:25 PM, Brian Kemp <[email-masked]> wrote:
> Randall - That is how mine is too.  I thought that is how they all worked.
>  You spray on the desired solution at low pressure and let is soak in then
> switch to high to actually clean and rinse.  It lets you wash then rinse a
> section at a time without having to make changes to the pressure washer.  I
> can see this feature being really handy if you are doing a house while on a
> ladder.
>
> Brian
>
>
>> Unsubscribe/Manage:
>> http://autox.team.net/mailman/options/shop-talk/[email-masked]
>
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/shop-talk/[email-masked]

[email-masked]