Subject: [Mgs] Review of the MGB

From: Mark Bradakis <[email-masked]>
Date: Mon, 16 Mar 2026 13:30:36 -0600

Another video from Jack at Number 27.

https://www.youtube.com/watch?v=pu_3pX93_sk

mjb.

_______________________________________________

[email-masked]

Archive: http://www.team.net/pipermail/mgs http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

---

From: dave northrup <[email-masked]>
Date: Wed, 18 Mar 2026 20:09:01 +0000

Excellent.  Worth the watch

-----Original Message-----
From: Mgs <[email-masked]> On Behalf Of Mark Bradakis
Sent: Monday, March 16, 2026 2:31 PM
To: [email-masked]
Subject: [Mgs] Review of the MGB

mjb.

[email-masked]

Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]
_______________________________________________

[email-masked]