Subject: Re: [Mgs] fuel pump problems, need help

From: Eric J Russell via Mgs <[email-masked]>
Date: Tue, 19 Jul 2016 16:27:03 -0400

> 62 MGA, fuel won't pump. I disassembled my pump and checked the diaphragm,
> the rubber looked really good, I replaced the cork seal for what looks 
> like
> the overflow tank, this is not the original kind of pump with the
> unscrew-able filter. >

> I would think as long as the piston is going up and down I should at least
> get a stronger vacuum. What do I do? What is wrong?

I am not sure what type of fuel pump you are describing. Can you post a link 
to a photo?

SU pumps don't suck very well. The fuel pump in the MGA is mounted fairly 
low so it doesn't have to draw fuel up. Once primed all it needs to do is 
push fuel up to the carbs.

Eric Russell
Mebane, NC 

_______________________________________________

[email-masked]
Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

---

From: Clayton Kirkwood via Mgs <[email-masked]>
Date: Thu, 21 Jul 2016 10:13:28 -0700

How does one go about priming the pump?

crk

> -----Original Message-----
> From: Eric J Russell [mailto:[email-masked]]
> Sent: Tuesday, July 19, 2016 1:27 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Mgs] fuel pump problems, need help
> 
> > 62 MGA, fuel won't pump. I disassembled my pump and checked the
> > diaphragm, the rubber looked really good, I replaced the cork seal for
> > what looks like the overflow tank, this is not the original kind of
> > pump with the unscrew-able filter. >
> 
> > I would think as long as the piston is going up and down I should at
> > least get a stronger vacuum. What do I do? What is wrong?
> 
> I am not sure what type of fuel pump you are describing. Can you post a
link to
> a photo?
low
> so it doesn't have to draw fuel up. Once primed all it needs to do is push
fuel up
> to the carbs.

[email-masked]