Subject: Re: [Mgs] 1971 MGB front pulley split, any advice on replacement?

From: Simon Matthews <[email-masked]>
Date: Sun, 23 Jun 2013 18:38:54 -0700

I was able to remove the radiator and eventually remove the bolt holding in
the front pulley.

Next question: how to get the front pulley off the shaft?

Simon

On Sat, Jun 22, 2013 at 5:52 PM, Simon Matthews
<[email-masked]>wrote:

> The front pulley on my daughter's '71 MGB has split (outer turns
> independently of inner).
>
> Any advice on replacement? I have a compressor and impact wrench, so I
> should not have problems removing the bolt, once I can get to it. What size
> is the bolt? I need to make sure I have a suitable socket.
>
> I did this some years ago on my MGA, but was wondering if there are any
> extra considerations for the MGB?
>
> Also, is it safe to forget to replace the belt that drives the air pump
> (smog pump)?
>
> Simon
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

---

From: Simon Matthews <[email-masked]>
Date: Sun, 23 Jun 2013 22:57:08 -0700

I must have had one of these to replace the front pulley on my MGA, but I
can't find it.

Simon

On Sun, Jun 23, 2013 at 6:59 PM, Max Heim <[email-masked]> wrote:

> With a harmonic balancer puller. You can probably rent/borrow one at
> O'Reilly's or Autozone.
>
> Hmm, you're in the bay area, aren't you? You could borrow mine, though to
> be
> honest I don't think I've tested it on the MG. I got it for my Plymouth.
>
> --
>
> Max Heim
> '66 MGB GHN3L76149
> If you're near Menlo Park, CA,
> it's the primer red one with chrome wires
>
>
> on 6/23/13 6:38 PM, Simon Matthews at [email-masked] wrote:
>
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Forums: http://www.team.net/forums
> Unsubscribe:
> http://autox.team.net/mailman/options/mgs/[email-masked]

[email-masked]

---

From: "PaulHunt73" <[email-masked]>
Date: Mon, 24 Jun 2013 08:03:04 +0100

Should slide off the Woodruff key, maybe need a bit of 'encouragement'.

PaulH.

----- Original Message ----- 

[email-masked]