Subject: Re: [Mgs] gen to alt

From: "PaulHunt73" <[email-masked]>
Date: Sat, 27 Oct 2012 15:40:41 +0100

Depends how original you want it to be, and whether the output of the dynamo 
is sufficient for your usage.  These cars ran perfectly well for many years, 
and many still do, on dynamos, alternators were required for the higher 
loads of more modern cars.  A similar question is often asked of MGBs, and 
that is "should I uprate my alternator?", and the answer is just the same. 
I've never had a problem with the factory-rated alts on either of mine.

PaulH.

----- Original Message ----- 
> If I find that my generator is not working should I go to an alternator?
> 1957 MGA 1500
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

---

From: Barney Gaylord <[email-masked]>
Date: Sat, 27 Oct 2012 10:04:54 -0500

Generator is often cheap and easy to repair, commonly only needs 
brushes.  However, if the generator is melted inside due to a failed 
control box, that would be a good time to consider the alternator 
conversion.  In recent years replacement control boxes have been 
notoriously unreliable.  When a regulator relay fails, the bad $40 
control box takes out a good $100 generaor along with it.

Barney Gaylord
1958 MGA with an attitude
http://MGAguru.com

[email-masked]

---

From: "Bob Donahue" <[email-masked]>
Date: Sun, 28 Oct 2012 15:29:43 -0400

I agree. Alternators have reliable solid state regulators built in. Relay 
type regulators, that generators use, are the weakest link in the charging 
system, IMHO.

Bob Donahue (Still Stuck in the '50s)
Email - [email-masked]
Cars:       52 MGTD - #17639
               71 MGB - #GHN5UB254361
Member:  NEMGTR #11470
               NAMGBR # 7-3336
               Hoosier MGB Club
               Olde Octagons of Indiana

----- Original Message ----- 
From: "Barney Gaylord" <[email-masked]>
To: "Tom Gunderson" <[email-masked]>; "Mga List" <[email-masked]>
Sent: Saturday, October 27, 2012 11:04 AM
Subject: Re: [Mgs] gen to alt

> Generator is often cheap and easy to repair, commonly only needs brushes. 
> However, if the generator is melted inside due to a failed control box, 
> that would be a good time to consider the alternator conversion.  In 
> recent years replacement control boxes have been notoriously unreliable. 
> When a regulator relay fails, the bad $40 control box takes out a good 
> $100 generaor along with it.
>
> Barney Gaylord

[email-masked]

---

From: Paul Osborne <[email-masked]>
Date: Sun, 28 Oct 2012 21:11:46 -0400

BUT, you can purchase a solid state regulator, install it in your relay
regulator box , and all looks orig.

paul o

> ----- Original Message ----- From: "Barney Gaylord" <[email-masked]>
However, if the generator is melted inside due to a failed control box, that
would be a good time to consider the alternator conversion.  In recent years
replacement control boxes have been notoriously unreliable. When a regulator
relay fails, the bad $40 control box takes out a good $100 generaor along with
it.
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Forums: http://www.team.net/forums
> Unsubscribe:
http://autox.team.net/mailman/options/mgs/[email-masked]
_______________________________________________

[email-masked]

---

From: "Bob Donahue" <[email-masked]>
Date: Tue, 30 Oct 2012 21:03:49 -0400

Wow, where can I purchase one of these solid state generator regulators for 
my TD?

Electrical contacts have limited life under rapid, constant switching. 
Transistors can do the job with no wear. I love my Pertronix Ignitor. If I 
can get a solid state regulator, I will love it also.

----- Original Message ----- 
From: "Paul Osborne" <[email-masked]>
To: "Bob Donahue" <[email-masked]>
Cc: "mgs" <[email-masked]>
Sent: Sunday, October 28, 2012 9:11 PM
Subject: Re: [Mgs] gen to alt

paul o

[email-masked]

---

From: [email-masked]
Date: Tue, 30 Oct 2012 20:42:26 -0500 (CDT)

Just got one and it works great.

http://wiltonae.com/home/index.aspx

Give Bob Jeffers a call
and then you'll have to give him some data about your generator.

Good luck!

Dave W.
59 MGA 1500

Wow, where can I purchase one of these solid state generator regulators
> for
> Electrical contacts have
limited life under rapid, constant switching.
> Transistors can do
the job with no wear. I love my Pertronix Ignitor. If I
> can get
a solid state regulator, I will love it also.
>                71 MGB -
#GHN5UB254361
NAMGBR # 7-3336
        Olde Octagons of Indiana
> ----- Original
Message -----
From: "Paul Osborne"
<[email-masked]>
>> I agree. Alternators have reliable solid state regulators built
in.
>> Relay
>> type regulators, that generators
use, are the weakest link in the
>> charging
system, IMHO.
>> Cars:      
52 MGTD - #17639
>>              NAMGBR #
7-3336
   Olde Octagons of Indiana
[email-masked]
> Archive:
http://autox.team.net/mailman/options/mgs/[email-masked]
_______________________________________________

[email-masked]

---

From: "\" Just Brits \" Shop" <[email-masked]>
Date: Tue, 30 Oct 2012 20:45:05 -0500

<< On 10/30/2012 8:03 PM, Bob Donahue wrote:
> Wow, where can I purchase one of these solid state generator 
> regulators for my TD?>>

Don't you  READ The Octagon, Bob ??  Also, plenty on them in Archives 
<G> ! ! !

Ed

[email-masked]