Subject: [Mgs] OT, 40DCOE/18 rebuilds

From: Rick Lindsay <[email-masked]>
Date: Wed, 12 Sep 2012 10:13:30 -0700 (PDT)

Hello Friends,

A number of you expressed interest in following the rebuild of Jack's '65 Elan's Weber 40DCOE/18 carbs.  I posted a few picture links earlier.  If interested, you may have seen them.  Today I write just to report that the first carb's rebuild is progressing nicely.

The carburetter is disassembled, which was no minor feat given that it was glued together with 10 years of gum.  Still, the Chem-Dip did its job on most bits.  RustEater freed the remaining bits (like the choke valves).  And I can now report that the carb body is clean (and beautiful) with all passages clean, clear and undamaged, awaiting reassembly.  All jets and tubes have also been cleaned and are undamaged.  Next step is to verify that the various jets and tubes match the stock Elan specification.  Who knows what monkeying-around may have been done by some PO.

Jack brought the rebuild kits over to me last weekend so I have everything I need to put the first of these instruments back together.  I'll share photos of the whole reassembly, starting with setting the float level properly.  

Until then...

regards,

-rick
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

---

From: Charley & Peggy Robinson <[email-masked]>
Date: Thu, 13 Sep 2012 07:07:52 -0500

You might want to repost the link for those of us who missed it earlier.

CR

[email-masked]