Subject: Re: [Mgs] Rick Brown

From: "David F. Darby" <[email-masked]>
Date: Mon, 10 Sep 2012 10:59:26 -0500

Dave,

Thanks for the note. I'm really saddened to hear that. Rick was such a
great, convivial guy. He will be missed.

David

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of W. David Houser
Sent: Monday, September 10, 2012 10:17 AM
To: MGList List
Subject: [Mgs] Rick Brown

Listers,
Some sad news about one of our MG family.
Rick Brown passed after his long battle.
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

---

From: Dan DiBiase <[email-masked]>
Date: Mon, 10 Sep 2012 10:08:26 -0700 (PDT)

Oh what a shame. I met Rick several times here in NJ before he moved south. A
nice guy for sure.

Dan D

________________________________
 From: W. David
Houser <[email-masked]>
To: MGList List <[email-masked]> 
Sent:
Monday, September 10, 2012 11:16 AM
Subject: [Mgs] Rick Brown
 
Listers,
Some
sad news about one of our MG family.
Rick Brown passed after his long battle.
Rick was the webmaster for several of
our MG national organizations and was
recently honored for all his outstanding
service with an American MGC Register
Award presented at a past Club Breakfast
by Jeff Zorn of LBC. He received a
Special Award of Service from NAMGBR
recently, as well. He was a proud member
of NAMGAR and the Mini Register.
Rick belonged to our local Nature Coast
English Car Club/Suncoast Classic MG
Club here in Brooksville, FL.
He was a
good friend and will be missed.
_______________________________________________

[email-masked]
Donate:
Archive:
Unsubscribe:
http://autox.team.net/mailman/options/mgs/[email-masked]
_______________________________________________

[email-masked]