Subject: [Healeys] big Healey new steering box

From: Ken Freese via Healeys <[email-masked]>
Date: Sat, 20 Jun 2026 10:34:21 -0700

Are there any negatives to the new steering boxes aside from the cost?
Ken Freese
65 BJ8
_______________________________________________

Archive: http://www.team.net/pipermail/healeys http://autox.team.net/archive/healeys

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: "s.hutchings via Healeys" <[email-masked]>
Date: Sun, 21 Jun 2026 17:59:22 -0400

--===============2979407281912941430==

----_com.samsung.android.email_2899222511300470
Content-Transfer-Encoding: base64

----_com.samsung.android.email_2899222511300470
Content-Transfer-Encoding: base64

----_com.samsung.android.email_2899222511300470--

--===============2979407281912941430==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============2979407281912941430==--